gnu: coreutils: Fix cross-compilation.

* gnu/packages/patches/coreutils-fix-cross-compilation.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/base.scm (coreutils)[source]: Use it.
master
Manolis Ragkousis 2017-01-18 20:48:27 +02:00
parent ef00f3ebae
commit 82a7a8c667
No known key found for this signature in database
GPG Key ID: 327C1EF38DF54C32
3 changed files with 18 additions and 1 deletions

View File

@ -510,6 +510,7 @@ dist_patch_DATA = \
%D%/packages/patches/clx-remove-demo.patch \
%D%/packages/patches/cmake-fix-tests.patch \
%D%/packages/patches/coda-use-system-libs.patch \
%D%/packages/patches/coreutils-fix-cross-compilation.patch \
%D%/packages/patches/cpio-CVE-2016-2037.patch \
%D%/packages/patches/cpufrequtils-fix-aclocal.patch \
%D%/packages/patches/cracklib-CVE-2016-6318.patch \

View File

@ -291,7 +291,8 @@ used to apply commands with arbitrarily long arguments.")
version ".tar.xz"))
(sha256
(base32
"13lspazc7xkviy93qz7ks9jv4sldvgmwpq36ghrbrqpq93br8phm"))))
"13lspazc7xkviy93qz7ks9jv4sldvgmwpq36ghrbrqpq93br8phm"))
(patches (search-patches "coreutils-fix-cross-compilation.patch"))))
(build-system gnu-build-system)
(inputs `(("acl" ,acl) ; TODO: add SELinux
("gmp" ,gmp) ;bignums in 'expr', yay!

View File

@ -0,0 +1,15 @@
Coreutils fails to cross compile for other platforms because cu_install_program
is not being evaluated properly. This patch fixes it.
See <https://lists.gnu.org/archive/html/coreutils/2017-01/msg00039.html>
--- a/Makefile.in
+++ b/Makefile.in
@@ -5023,7 +5023,7 @@ pr = progs-readme
@CROSS_COMPILING_FALSE@cu_install_program = src/ginstall
# Use the just-built 'ginstall', when not cross-compiling.
-@CROSS_COMPILING_TRUE@cu_install_program = @INSTALL_PROGRAM@
+@CROSS_COMPILING_TRUE@cu_install_program := @INSTALL@
info_TEXINFOS = doc/coreutils.texi
doc_coreutils_TEXINFOS = \
doc/perm.texi \