gnu: python-pyopenssl: Update to 17.0.0.

* gnu/packages/python.scm (python-pyopenssl, python2-pyopenssl): Update to 17.0.0.
[native-inputs]: Change PYTHON-PYTEST to PYTHON-PYTEST-3.0.
* gnu/packages/patches/python-pyopenssl-skip-network-test.patch: Adjust.
This commit is contained in:
Marius Bakke 2017-04-21 14:25:05 +02:00
parent a7d12a9e71
commit 833df99d62
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
2 changed files with 12 additions and 19 deletions

View File

@ -7,20 +7,14 @@ diff --git a/tests/test_ssl.py b/tests/test_ssl.py
index ee849fd..60048b8 100644 index ee849fd..60048b8 100644
--- a/tests/test_ssl.py --- a/tests/test_ssl.py
+++ b/tests/test_ssl.py +++ b/tests/test_ssl.py
@@ -1180,40 +1180,6 @@ class ContextTests(TestCase, _LoopbackMixin): @@ -1113,33 +1113,6 @@ class TestContext(object):
TypeError, context.load_verify_locations, None, None, None reason="set_default_verify_paths appears not to work on Windows. "
) "See LP#404343 and LP#404344."
)
- @pytest.mark.skipif(
- platform == "win32",
- reason="set_default_verify_paths appears not to work on Windows. "
- "See LP#404343 and LP#404344."
- )
- def test_set_default_verify_paths(self): - def test_set_default_verify_paths(self):
- """ - """
- :py:obj:`Context.set_default_verify_paths` causes the - `Context.set_default_verify_paths` causes the platform-specific CA
- platform-specific CA certificate locations to be used for - certificate locations to be used for verification purposes.
- verification purposes.
- """ - """
- # Testing this requires a server with a certificate signed by one - # Testing this requires a server with a certificate signed by one
- # of the CAs in the platform CA location. Getting one of those - # of the CAs in the platform CA location. Getting one of those
@ -43,8 +37,7 @@ index ee849fd..60048b8 100644
- clientSSL.set_connect_state() - clientSSL.set_connect_state()
- clientSSL.do_handshake() - clientSSL.do_handshake()
- clientSSL.send(b"GET / HTTP/1.0\r\n\r\n") - clientSSL.send(b"GET / HTTP/1.0\r\n\r\n")
- self.assertTrue(clientSSL.recv(1024)) - assert clientSSL.recv(1024)
-
def test_set_default_verify_paths_signature(self): def test_add_extra_chain_cert_invalid_cert(self):
""" """
:py:obj:`Context.set_default_verify_paths` takes no arguments and

View File

@ -7323,14 +7323,14 @@ message digests and key derivation functions.")
(define-public python-pyopenssl (define-public python-pyopenssl
(package (package
(name "python-pyopenssl") (name "python-pyopenssl")
(version "16.2.0") (version "17.0.0")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
(uri (pypi-uri "pyOpenSSL" version)) (uri (pypi-uri "pyOpenSSL" version))
(sha256 (sha256
(base32 (base32
"0vji4yrfshs15xpczbhzhasnjrwcarsqg87n98ixnyafnyxs6ybp")) "1pdg1gpmkzj8yasg6cmkhcivxcdp4c12nif88y4qvsxq5ffzxas8"))
(patches (patches
(search-patches "python-pyopenssl-skip-network-test.patch")))) (search-patches "python-pyopenssl-skip-network-test.patch"))))
(build-system python-build-system) (build-system python-build-system)
@ -7348,7 +7348,7 @@ message digests and key derivation functions.")
(inputs (inputs
`(("openssl" ,openssl))) `(("openssl" ,openssl)))
(native-inputs (native-inputs
`(("python-pytest" ,python-pytest))) `(("python-pytest" ,python-pytest-3.0)))
(home-page "https://github.com/pyca/pyopenssl") (home-page "https://github.com/pyca/pyopenssl")
(synopsis "Python wrapper module around the OpenSSL library") (synopsis "Python wrapper module around the OpenSSL library")
(description (description