gnu: lcms: Fix an out-of-bounds read.

* gnu/packages/patches/lcms-fix-out-of-bounds-read.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/ghostscript.scm (lcms)[replacement]: New field.
[properties]: Specify the 'cpe-name'.
(lcms/fixed): New variable.
master
Leo Famulari 2017-01-23 01:31:24 -05:00
parent bed2e0dfd1
commit 84b60a7cdf
No known key found for this signature in database
GPG Key ID: 2646FA30BACA7F08
3 changed files with 44 additions and 0 deletions

View File

@ -655,6 +655,7 @@ dist_patch_DATA = \
%D%/packages/patches/kobodeluxe-midicon-segmentation-fault.patch \
%D%/packages/patches/kobodeluxe-graphics-window-signed-char.patch \
%D%/packages/patches/laby-make-install.patch \
%D%/packages/patches/lcms-fix-out-of-bounds-read.patch \
%D%/packages/patches/ldc-disable-tests.patch \
%D%/packages/patches/liba52-enable-pic.patch \
%D%/packages/patches/liba52-link-with-libm.patch \

View File

@ -39,6 +39,7 @@
(define-public lcms
(package
(name "lcms")
(replacement lcms/fixed)
(version "2.6")
(source (origin
(method url-fetch)
@ -58,6 +59,14 @@ Consortium standard (ICC), approved as ISO 15076-1.")
(license license:x11)
(home-page "http://www.littlecms.com/")))
(define lcms/fixed
(package
(inherit lcms)
(source
(origin
(inherit (package-source lcms))
(patches (search-patches "lcms-fix-out-of-bounds-read.patch"))))))
(define-public libpaper
(package
(name "libpaper")

View File

@ -0,0 +1,34 @@
Fix an out-of-bounds heap read in Type_MLU_Read():
http://seclists.org/oss-sec/2016/q3/288
https://bugzilla.redhat.com/show_bug.cgi?id=1367357
Patch copied from upstream source repository:
https://github.com/mm2/Little-CMS/commit/5ca71a7bc18b6897ab21d815d15e218e204581e2
From 5ca71a7bc18b6897ab21d815d15e218e204581e2 Mon Sep 17 00:00:00 2001
From: Marti <marti.maria@tktbrainpower.com>
Date: Mon, 15 Aug 2016 23:31:39 +0200
Subject: [PATCH] Added an extra check to MLU bounds
Thanks to Ibrahim el-sayed for spotting the bug
---
src/cmstypes.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/cmstypes.c b/src/cmstypes.c
index cb61860..c7328b9 100644
--- a/src/cmstypes.c
+++ b/src/cmstypes.c
@@ -1460,6 +1460,7 @@ void *Type_MLU_Read(struct _cms_typehandler_struct* self, cmsIOHANDLER* io, cmsU
// Check for overflow
if (Offset < (SizeOfHeader + 8)) goto Error;
+ if ((Offset + Len) > SizeOfTag + 8) goto Error;
// True begin of the string
BeginOfThisString = Offset - SizeOfHeader - 8;
--
2.11.0