Merge branch 'staging' into core-updates

Conflicts:
	gnu/local.mk: Missing mention of gdk-pixbuf-list-dir.patch in the
	commit log really confused me here... It's from 8c6b077bfa (staging).
	gnu/packages/xorg.scm: xkeyboard-config updated both places.
This commit is contained in:
Marius Bakke 2017-02-21 14:31:36 +01:00
commit 8505eb19a4
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
12 changed files with 80 additions and 29 deletions

View File

@ -575,6 +575,7 @@ dist_patch_DATA = \
%D%/packages/patches/gcc-6-arm-none-eabi-multilib.patch \ %D%/packages/patches/gcc-6-arm-none-eabi-multilib.patch \
%D%/packages/patches/gcc-6-cross-environment-variables.patch \ %D%/packages/patches/gcc-6-cross-environment-variables.patch \
%D%/packages/patches/gcj-arm-mode.patch \ %D%/packages/patches/gcj-arm-mode.patch \
%D%/packages/patches/gdk-pixbuf-list-dir.patch \
%D%/packages/patches/gd-fix-chunk-size-on-boundaries.patch \ %D%/packages/patches/gd-fix-chunk-size-on-boundaries.patch \
%D%/packages/patches/gd-fix-gd2-read-test.patch \ %D%/packages/patches/gd-fix-gd2-read-test.patch \
%D%/packages/patches/gd-fix-tests-on-i686.patch \ %D%/packages/patches/gd-fix-tests-on-i686.patch \

View File

@ -34,7 +34,7 @@
(define-public boost (define-public boost
(package (package
(name "boost") (name "boost")
(version "1.61.0") (version "1.63.0")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append (uri (string-append
@ -43,7 +43,7 @@
".tar.bz2")) ".tar.bz2"))
(sha256 (sha256
(base32 (base32
"0h5nk7pgxf7xsvvshj9qfpsfp9wx6gq9r78n3nx736pxq83bsix5")))) "1c5kzhcqahnic55dxcnw7r80qvwx5sfa2sa97yzv7xjrywljbbmy"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(inputs `(("zlib" ,zlib))) (inputs `(("zlib" ,zlib)))
(native-inputs (native-inputs

View File

@ -87,6 +87,7 @@
`(#:make-flags (list (string-append "PREFIX=" %output)) `(#:make-flags (list (string-append "PREFIX=" %output))
#:configure-flags #:configure-flags
`("--disable-driverless" ; TODO: enable this `("--disable-driverless" ; TODO: enable this
"--disable-mutool" ; depends on yet another PDF library (mupdf)
,(string-append "--with-test-font-path=" ,(string-append "--with-test-font-path="
(assoc-ref %build-inputs "font-dejavu") (assoc-ref %build-inputs "font-dejavu")
"/share/fonts/truetype/DejaVuSans.ttf") "/share/fonts/truetype/DejaVuSans.ttf")
@ -113,7 +114,6 @@
("libjpeg" ,libjpeg) ("libjpeg" ,libjpeg)
("libpng" ,libpng) ("libpng" ,libpng)
("libtiff" ,libtiff) ("libtiff" ,libtiff)
("mupdf" ,mupdf)
("glib" ,glib) ("glib" ,glib)
("qpdf" ,qpdf) ("qpdf" ,qpdf)
("poppler" ,poppler) ("poppler" ,poppler)

View File

@ -3,6 +3,7 @@
;;; Copyright © 2014, 2016 Andreas Enge <andreas@enge.fr> ;;; Copyright © 2014, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org> ;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org> ;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
;;; ;;;
;;; This file is part of GNU Guix. ;;; This file is part of GNU Guix.
;;; ;;;
@ -26,6 +27,7 @@
#:use-module (guix build-system gnu) #:use-module (guix build-system gnu)
#:use-module (guix build-system cmake) #:use-module (guix build-system cmake)
#:use-module (gnu packages) #:use-module (gnu packages)
#:use-module (gnu packages bash)
#:use-module (gnu packages python) #:use-module (gnu packages python)
#:use-module (gnu packages bison) #:use-module (gnu packages bison)
#:use-module (gnu packages docbook) #:use-module (gnu packages docbook)
@ -99,8 +101,18 @@ markup) can be customized and extended by the user.")
("flex" ,flex) ("flex" ,flex)
("libxml2" ,libxml2) ; provides xmllint for the tests ("libxml2" ,libxml2) ; provides xmllint for the tests
("python" ,python-2))) ; for creating the documentation ("python" ,python-2))) ; for creating the documentation
(inputs
`(("bash" ,bash-minimal)))
(arguments (arguments
`(#:test-target "tests")) `(#:test-target "tests"
#:phases (modify-phases %standard-phases
(add-before 'configure 'patch-sh
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/portable.cpp"
(("/bin/sh")
(string-append
(assoc-ref inputs "bash") "/bin/sh")))
#t)))))
(home-page "http://www.stack.nl/~dimitri/doxygen/") (home-page "http://www.stack.nl/~dimitri/doxygen/")
(synopsis "Generate documentation from annotated sources") (synopsis "Generate documentation from annotated sources")
(description "Doxygen is the de facto standard tool for generating (description "Doxygen is the de facto standard tool for generating

View File

@ -274,14 +274,14 @@ Python.")
(define-public wayland (define-public wayland
(package (package
(name "wayland") (name "wayland")
(version "1.11.0") (version "1.12.0")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://wayland.freedesktop.org/releases/" (uri (string-append "https://wayland.freedesktop.org/releases/"
name "-" version ".tar.xz")) name "-" version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"1c0d5ivy9n44hykvw2ggrvqrnn7naw3wg11vbvgwzgi8g5gr4h4m")))) "1c8sha5vm8w346wcbvgnjihisxfyvrr3qlbmfb5sp201p9f17d6n"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments `(#:parallel-tests? #f)) (arguments `(#:parallel-tests? #f))
(native-inputs (native-inputs
@ -331,7 +331,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
(define-public weston (define-public weston
(package (package
(name "weston") (name "weston")
(version "1.11.0") (version "1.12.0")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append (uri (string-append
@ -339,7 +339,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
"weston-" version ".tar.xz")) "weston-" version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"09biddxw3ar797kxf9mywjkb2iwky6my39gpp51ni846y7lqdq05")))) "0cshmw4ql4cr36v90bbi4qi6plvb6b9dbpnc3w9m17rv5siw4ymc"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(native-inputs (native-inputs
`(("pkg-config" ,pkg-config) `(("pkg-config" ,pkg-config)
@ -372,9 +372,11 @@ applications, X servers (rootless or fullscreen) or other display servers.")
;; Use elogind instead of systemd ;; Use elogind instead of systemd
(substitute* "configure" (substitute* "configure"
(("libsystemd-login >= 198") "libelogind")) (("libsystemd-login >= 198") "libelogind"))
(substitute* '("src/launcher-logind.c" "src/weston-launch.c") (substitute* '("libweston/launcher-logind.c"
"libweston/weston-launch.c")
(("#include <systemd/sd-login.h>") (("#include <systemd/sd-login.h>")
"#include <elogind/sd-login.h>")))) "#include <elogind/sd-login.h>"))
#t))
(add-after 'configure 'patch-confdefs.h (add-after 'configure 'patch-confdefs.h
(lambda _ (lambda _
(system "echo \"#define HAVE_SYSTEMD_LOGIN_209 1\" >> confdefs.h"))) (system "echo \"#define HAVE_SYSTEMD_LOGIN_209 1\" >> confdefs.h")))

View File

@ -197,7 +197,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa (define-public mesa
(package (package
(name "mesa") (name "mesa")
(version "13.0.3") (version "13.0.4")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
@ -205,7 +205,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")) version "/mesa-" version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"03m4gc6qc50lb0ic06f83r3yl0x4lmj2zjq3sl60vl3nq7jqpanr")) "09p740qvmf4vqnpgxxlizk0dhdhj6i519qsbbrc8hpxxyzl7qpd9"))
(patches (patches
(search-patches "mesa-wayland-egl-symbols-check-mips.patch")))) (search-patches "mesa-wayland-egl-symbols-check-mips.patch"))))
(build-system gnu-build-system) (build-system gnu-build-system)

View File

@ -432,7 +432,8 @@ highlighting and other features typical of a source code editor.")
name "-" version ".tar.xz")) name "-" version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"1v1rssjd8p5s3lymsfhiq5mbs2pc0h1r6jd0asrwdbrign7i68sj")))) "1v1rssjd8p5s3lymsfhiq5mbs2pc0h1r6jd0asrwdbrign7i68sj"))
(patches (search-patches "gdk-pixbuf-list-dir.patch"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments (arguments
'(#:configure-flags '("--with-x11") '(#:configure-flags '("--with-x11")

View File

@ -0,0 +1,35 @@
Sort directory entries so that the output of
gdk-pixbuf-query-loaders is deterministic.
See: https://bugzilla.gnome.org/show_bug.cgi?id=777332
--- gdk-pixbuf-2.34.0/gdk-pixbuf/queryloaders.c.orig 2017-01-11 00:17:32.865843062 +0100
+++ gdk-pixbuf-2.34.0/gdk-pixbuf/queryloaders.c 2017-01-16 16:12:03.420667874 +0100
@@ -354,16 +354,27 @@
dir = g_dir_open (path, 0, NULL);
if (dir) {
+ GList *entries = NULL;
const char *dent;
while ((dent = g_dir_read_name (dir))) {
gint len = strlen (dent);
if (len > SOEXT_LEN &&
strcmp (dent + len - SOEXT_LEN, SOEXT) == 0) {
- query_module (contents, path, dent);
+ entries = g_list_append (entries, g_strdup (dent));
}
}
g_dir_close (dir);
+ /* Sort directory entries so that the output of
+ gdk-pixbuf-query-loaders is deterministic. */
+ entries = g_list_sort (entries, (GCompareFunc) strcmp);
+ GList *xentries;
+ for (xentries = entries; xentries; xentries = g_list_next (xentries)) {
+ dent = xentries->data;
+ query_module (contents, path, dent);
+ g_free (xentries->data);
+ }
+ g_list_free (entries);
}
#else
g_string_append_printf (contents, "# dynamic loading of modules not supported\n");

View File

@ -42,14 +42,14 @@
(define-public libsndfile (define-public libsndfile
(package (package
(name "libsndfile") (name "libsndfile")
(version "1.0.26") (version "1.0.27")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "http://www.mega-nerd.com/libsndfile/files/libsndfile-" (uri (string-append "http://www.mega-nerd.com/libsndfile/files/libsndfile-"
version ".tar.gz")) version ".tar.gz"))
(sha256 (sha256
(base32 (base32
"14jhla289cj45946h0hq2an0a9g4wkwb3v4571bla6ixfvn20rfd")))) "1h7s61nhf7vklh9sdsbbqzb6x287q4x4j1jc5gmjragl4wprb4d3"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(inputs (inputs
`(("libvorbis" ,libvorbis) `(("libvorbis" ,libvorbis)

View File

@ -138,14 +138,14 @@ avoiding password prompts when X11 forwarding has already been setup.")
(define-public libxkbcommon (define-public libxkbcommon
(package (package
(name "libxkbcommon") (name "libxkbcommon")
(version "0.6.1") (version "0.7.1")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "http://xkbcommon.org/download/" name "-" (uri (string-append "https://xkbcommon.org/download/" name "-"
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"0q47xa1szlxwgvwmhv4b7xwawnykz1hnc431d84nj8dlh2q8f22v")))) "12z6hih3n1r0asp2hzp9qsiwdfkfz46jwp06x8kprr0r5rfk0nds"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(inputs (inputs
`(("libx11" ,libx11) `(("libx11" ,libx11)
@ -162,7 +162,7 @@ avoiding password prompts when X11 forwarding has already been setup.")
(string-append "--with-x-locale-root=" (string-append "--with-x-locale-root="
(assoc-ref %build-inputs "libx11") (assoc-ref %build-inputs "libx11")
"/share/X11/locale")))) "/share/X11/locale"))))
(home-page "http://xkbcommon.org/") (home-page "https://xkbcommon.org/")
(synopsis "Library to handle keyboard descriptions") (synopsis "Library to handle keyboard descriptions")
(description "Xkbcommon is a library to handle keyboard descriptions, (description "Xkbcommon is a library to handle keyboard descriptions,
including loading them from disk, parsing them and handling their including loading them from disk, parsing them and handling their
@ -273,7 +273,7 @@ rasterisation.")
(define-public libdrm (define-public libdrm
(package (package
(name "libdrm") (name "libdrm")
(version "2.4.68") (version "2.4.75")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
@ -283,7 +283,7 @@ rasterisation.")
".tar.bz2")) ".tar.bz2"))
(sha256 (sha256
(base32 (base32
"1px91j6imaaq2fy8ksvgldmv0cdz3w379jqiciqvqa99jajxjjsv")) "0kq5hmck0gq7b29fr8jp94njc7jpkpbyws12s63w4b21xw750nid"))
(patches (search-patches "libdrm-symbol-check.patch")))) (patches (search-patches "libdrm-symbol-check.patch"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(inputs (inputs

View File

@ -127,7 +127,7 @@ compressed video format.")
(define speex (define speex
(package (package
(name "speex") (name "speex")
(version "1.2rc1") (version "1.2.0")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
@ -135,7 +135,7 @@ compressed video format.")
version ".tar.gz")) version ".tar.gz"))
(sha256 (sha256
(base32 (base32
"19mpkhbz3s08snvndn0h1dk2j139max6b0rr86nnsjmxazf30brl")))) "150047wnllz4r94whb9r73l5qf0z5z3rlhy98bawfbblmkq8mbpa"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(inputs `(("libogg" ,libogg))) (inputs `(("libogg" ,libogg)))
(home-page "https://gnu.org/software/speex") (home-page "https://gnu.org/software/speex")
@ -202,14 +202,14 @@ It currently supports:
(define flac (define flac
(package (package
(name "flac") (name "flac")
(version "1.3.1") (version "1.3.2")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "http://downloads.xiph.org/releases/flac/flac-" (uri (string-append "http://downloads.xiph.org/releases/flac/flac-"
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"0v65w7ph6ldwp5a8fbhp0a3w8f737ck468fr7yb7sxmskl4w0ws7")))) "0gymm2j3276kr9nz6vmgfwsdfrq6c449n40a0mzz8h6wc7nw7kwi"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments (arguments
`(#:parallel-tests? #f)) `(#:parallel-tests? #f))

View File

@ -3729,7 +3729,7 @@ extension to the X11 protocol. It includes:
(define-public xkeyboard-config (define-public xkeyboard-config
(package (package
(name "xkeyboard-config") (name "xkeyboard-config")
(version "2.19") (version "2.20")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
@ -3739,7 +3739,7 @@ extension to the X11 protocol. It includes:
".tar.bz2")) ".tar.bz2"))
(sha256 (sha256
(base32 (base32
"09sqyi430bbg13pp8j0j60p9p9xn2lpqx38xw1lyv77bp63d3pw3")))) "0d619g4r0w1f6q5qmaqjnsc0956gi02fqgpisqffzqy4acjwggyi"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(inputs (inputs
`(("gettext" ,gettext-minimal) `(("gettext" ,gettext-minimal)
@ -4800,7 +4800,7 @@ new API's in libXft, or the legacy API's in libX11.")
(define-public libxi (define-public libxi
(package (package
(name "libxi") (name "libxi")
(version "1.7.8") (version "1.7.9")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
@ -4810,7 +4810,7 @@ new API's in libXft, or the legacy API's in libX11.")
".tar.bz2")) ".tar.bz2"))
(sha256 (sha256
(base32 (base32
"1fr7mi4nbcxsa88qin9g2ipmzh595ydxy9qnabzl270laf6zmwnq")))) "0idg1wc01hndvaa820fvfs7phvd1ymf0lldmq6386i7rhkzvirn2"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(propagated-inputs (propagated-inputs
`(("inputproto" ,inputproto) `(("inputproto" ,inputproto)