gnu: libreoffice: Fix FTBFS with Boost 1.69.0.
* gnu/packages/patches/libreoffice-boost.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/libreoffice.scm (libreoffice)[source](patches): Add it.
This commit is contained in:
parent
0747328e31
commit
8576505422
|
@ -977,6 +977,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libmad-mips-newgcc.patch \
|
||||
%D%/packages/patches/libmygpo-qt-fix-qt-5.11.patch \
|
||||
%D%/packages/patches/libmygpo-qt-missing-qt5-modules.patch \
|
||||
%D%/packages/patches/libreoffice-boost.patch \
|
||||
%D%/packages/patches/libreoffice-icu.patch \
|
||||
%D%/packages/patches/libreoffice-glm.patch \
|
||||
%D%/packages/patches/libsndfile-armhf-type-checks.patch \
|
||||
|
|
|
@ -997,7 +997,8 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
|
|||
(sha256
|
||||
(base32
|
||||
"1dsd0gynjf7d6412dd2sx70xa2s8kld7ibyjdkwg5w9hhi2zxw2f"))))
|
||||
(search-patches "libreoffice-icu.patch"
|
||||
(search-patches "libreoffice-boost.patch"
|
||||
"libreoffice-icu.patch"
|
||||
"libreoffice-glm.patch")))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
|
|
|
@ -0,0 +1,17 @@
|
|||
Fix compatibility with newer Boost.
|
||||
|
||||
Extracted from this upstream commit:
|
||||
https://cgit.freedesktop.org/libreoffice/core/commit/?id=23a8d5ffbbe58761b89f590f0735abccd69a3681
|
||||
|
||||
diff --git a/sfx2/source/appl/shutdownicon.cxx b/sfx2/source/appl/shutdownicon.cxx
|
||||
--- a/sfx2/source/appl/shutdownicon.cxx
|
||||
+++ b/sfx2/source/appl/shutdownicon.cxx
|
||||
@@ -144,7 +144,7 @@ bool LoadModule()
|
||||
#endif // ENABLE_QUICKSTART_APPLET
|
||||
}
|
||||
assert(!boost::logic::indeterminate(loaded));
|
||||
- return loaded;
|
||||
+ return bool(loaded);
|
||||
}
|
||||
|
||||
}
|
Loading…
Reference in New Issue