gnu: mpc123: Add patch that fixes a segfault.

* gnu/packages/patches/mpc123-initialize-ao.patch: New file.
* gnu/packages/mp3.scm (mpc123): Use it.
* gnu-system.am (dist_patch_DATA): Add it.
master
Ludovic Courtès 2014-02-21 01:00:49 +01:00
parent 504a83af42
commit 86d07a5514
3 changed files with 22 additions and 1 deletions

View File

@ -298,6 +298,7 @@ dist_patch_DATA = \
gnu/packages/patches/make-impure-dirs.patch \
gnu/packages/patches/mcron-install.patch \
gnu/packages/patches/mit-krb5-init-fix.patch \
gnu/packages/patches/mpc123-initialize-ao.patch \
gnu/packages/patches/patchelf-page-size.patch \
gnu/packages/patches/perl-no-sys-dirs.patch \
gnu/packages/patches/plotutils-libpng-jmpbuf.patch \

View File

@ -298,7 +298,8 @@ format.")
version "/mpc123-" version ".tar.gz"))
(sha256
(base32
"0sf4pns0245009z6mbxpx7kqy4kwl69bc95wz9v23wgappsvxgy1"))))
"0sf4pns0245009z6mbxpx7kqy4kwl69bc95wz9v23wgappsvxgy1"))
(patches (list (search-patch "mpc123-initialize-ao.patch")))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-replace

View File

@ -0,0 +1,19 @@
Description: Zero ao_sample_format structure to cope with libao 1.0.0
Author: Colin Watson <cjwatson@debian.org>
Bug-Debian: http://bugs.debian.org/591396
Bug-Ubuntu: https://bugs.launchpad.net/bugs/710268
Forwarded: no
Last-Update: 2013-05-07
Index: b/ao.c
===================================================================
--- a/ao.c
+++ b/ao.c
@@ -123,6 +123,7 @@
/* initialize ao_format struct */
/* XXX VERY WRONG */
+ memset(&ao_fmt, 0, sizeof(ao_fmt));
ao_fmt.bits=16; /*tmp_stream_info.average_bitrate;*/
ao_fmt.rate=streaminfo->sample_freq;
ao_fmt.channels=streaminfo->channels;