gnu: curl: Update to 7.37.1.
* gnu/packages/curl.scm (curl): Update to 7.37.1. Remove patch. * gnu/packages/patches/curl-fix-test172.patch: Remove file. * gnu-system.am (dist_patch_DATA): Remove patch.
This commit is contained in:
parent
75f6f74f15
commit
87806dde17
|
@ -292,7 +292,6 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/cpio-gets-undeclared.patch \
|
gnu/packages/patches/cpio-gets-undeclared.patch \
|
||||||
gnu/packages/patches/cssc-gets-undeclared.patch \
|
gnu/packages/patches/cssc-gets-undeclared.patch \
|
||||||
gnu/packages/patches/cssc-missing-include.patch \
|
gnu/packages/patches/cssc-missing-include.patch \
|
||||||
gnu/packages/patches/curl-fix-test172.patch \
|
|
||||||
gnu/packages/patches/cursynth-wave-rand.patch \
|
gnu/packages/patches/cursynth-wave-rand.patch \
|
||||||
gnu/packages/patches/dbus-localstatedir.patch \
|
gnu/packages/patches/dbus-localstatedir.patch \
|
||||||
gnu/packages/patches/diffutils-gets-undeclared.patch \
|
gnu/packages/patches/diffutils-gets-undeclared.patch \
|
||||||
|
|
|
@ -1,5 +1,5 @@
|
||||||
;;; GNU Guix --- Functional package management for GNU
|
;;; GNU Guix --- Functional package management for GNU
|
||||||
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
|
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
|
@ -37,18 +37,14 @@
|
||||||
(define-public curl
|
(define-public curl
|
||||||
(package
|
(package
|
||||||
(name "curl")
|
(name "curl")
|
||||||
(version "7.35.0")
|
(version "7.37.1")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "http://curl.haxx.se/download/curl-"
|
(uri (string-append "http://curl.haxx.se/download/curl-"
|
||||||
version ".tar.lzma"))
|
version ".tar.lzma"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"14w5cwh6b1426lxkq6kp6h4vxryr4n7wfrrwhny1r4123q7n8ab9"))
|
"10yfh4hy8wbkj43la238hg6h8i9wyp1cvvk8kl0giac1020imn5d"))))
|
||||||
(patches
|
|
||||||
;; This patch fixes testcase 172 which uses a hardcoded cookie
|
|
||||||
;; expiration value which is expired as of Feb 1, 2014.
|
|
||||||
(list (search-patch "curl-fix-test172.patch")))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs `(("gnutls" ,gnutls)
|
(inputs `(("gnutls" ,gnutls)
|
||||||
("gss" ,gss)
|
("gss" ,gss)
|
||||||
|
|
|
@ -1,12 +0,0 @@
|
||||||
diff --git a/tests/data/test172 b/tests/data/test172
|
|
||||||
index b3efae9..3d53418 100644
|
|
||||||
--- a/tests/data/test172
|
|
||||||
+++ b/tests/data/test172
|
|
||||||
@@ -36,7 +36,7 @@ http://%HOSTIP:%HTTPPORT/we/want/172 -b log/jar172.txt -b "tool=curl; name=fool"
|
|
||||||
|
|
||||||
.%HOSTIP TRUE /silly/ FALSE 0 ismatch this
|
|
||||||
.%HOSTIP TRUE / FALSE 0 partmatch present
|
|
||||||
-%HOSTIP FALSE /we/want/ FALSE 1391252187 nodomain value
|
|
||||||
+%HOSTIP FALSE /we/want/ FALSE 2139150993 nodomain value
|
|
||||||
</file>
|
|
||||||
</client>
|
|
Loading…
Reference in New Issue