gnu: beets: Update to 1.3.18.
* gnu/packages/patches/beets-image-test-failure.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/music.scm (beets): Update to 1.3.18. [source]: Use patch.
This commit is contained in:
parent
69af462496
commit
88c8d72f3c
|
@ -442,6 +442,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/avrdude-fix-libusb.patch \
|
%D%/packages/patches/avrdude-fix-libusb.patch \
|
||||||
%D%/packages/patches/awesome-reproducible-png.patch \
|
%D%/packages/patches/awesome-reproducible-png.patch \
|
||||||
%D%/packages/patches/bash-completion-directories.patch \
|
%D%/packages/patches/bash-completion-directories.patch \
|
||||||
|
%D%/packages/patches/beets-image-test-failure.patch \
|
||||||
%D%/packages/patches/bigloo-gc-shebangs.patch \
|
%D%/packages/patches/bigloo-gc-shebangs.patch \
|
||||||
%D%/packages/patches/binutils-ld-new-dtags.patch \
|
%D%/packages/patches/binutils-ld-new-dtags.patch \
|
||||||
%D%/packages/patches/binutils-loongson-workaround.patch \
|
%D%/packages/patches/binutils-loongson-workaround.patch \
|
||||||
|
|
|
@ -1474,13 +1474,17 @@ websites such as Libre.fm.")
|
||||||
(define-public beets
|
(define-public beets
|
||||||
(package
|
(package
|
||||||
(name "beets")
|
(name "beets")
|
||||||
(version "1.3.17")
|
(version "1.3.18")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (pypi-uri name version))
|
(uri (string-append
|
||||||
|
"https://pypi.python.org/packages/"
|
||||||
|
"14/6f/c9c79c5339ab3ecced265ca18adbf5bae3d4058bae737b6164d738fb4d2c/"
|
||||||
|
name "-" version ".tar.gz"))
|
||||||
|
(patches (search-patches "beets-image-test-failure.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0yg7sp18sdpszkinhb0bi6yinbn316jy1baxrwiw0m4byrj3rr6c"))))
|
"09pgyywa5llbc36y0lrr21ywgsp8m2zx6p8ncf8hxik28knd5kld"))))
|
||||||
(build-system python-build-system)
|
(build-system python-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:python ,python-2 ; only Python 2 is supported
|
`(#:python ,python-2 ; only Python 2 is supported
|
||||||
|
|
|
@ -0,0 +1,46 @@
|
||||||
|
Fix test failure due to missing image library backend.
|
||||||
|
|
||||||
|
Cherry-picked from upstream:
|
||||||
|
https://github.com/beetbox/beets/commit/07c95a1bf16bf86c640436208dda828cc7df0181
|
||||||
|
|
||||||
|
From 07c95a1bf16bf86c640436208dda828cc7df0181 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Adrian Sampson <adrian@radbox.org>
|
||||||
|
Date: Thu, 2 Jun 2016 11:39:05 -0700
|
||||||
|
Subject: [PATCH] Require an imaging backend for fuzzy ratio tests
|
||||||
|
|
||||||
|
These fail outright if we don't have a way to get image sizes (e.g.,
|
||||||
|
ImageMagick).
|
||||||
|
---
|
||||||
|
test/test_art.py | 4 ++++
|
||||||
|
1 file changed, 4 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/test/test_art.py b/test/test_art.py
|
||||||
|
index 02d26f4..1b12b76 100644
|
||||||
|
--- a/test/test_art.py
|
||||||
|
+++ b/test/test_art.py
|
||||||
|
@@ -561,21 +561,25 @@ def test_respect_enforce_ratio_no(self):
|
||||||
|
self._assertImageIsValidArt(self.IMG_500x490, True)
|
||||||
|
|
||||||
|
def test_respect_enforce_ratio_px_above(self):
|
||||||
|
+ self._require_backend()
|
||||||
|
self.plugin.enforce_ratio = True
|
||||||
|
self.plugin.margin_px = 5
|
||||||
|
self._assertImageIsValidArt(self.IMG_500x490, False)
|
||||||
|
|
||||||
|
def test_respect_enforce_ratio_px_below(self):
|
||||||
|
+ self._require_backend()
|
||||||
|
self.plugin.enforce_ratio = True
|
||||||
|
self.plugin.margin_px = 15
|
||||||
|
self._assertImageIsValidArt(self.IMG_500x490, True)
|
||||||
|
|
||||||
|
def test_respect_enforce_ratio_percent_above(self):
|
||||||
|
+ self._require_backend()
|
||||||
|
self.plugin.enforce_ratio = True
|
||||||
|
self.plugin.margin_percent = (500 - 490) / 500 * 0.5
|
||||||
|
self._assertImageIsValidArt(self.IMG_500x490, False)
|
||||||
|
|
||||||
|
def test_respect_enforce_ratio_percent_below(self):
|
||||||
|
+ self._require_backend()
|
||||||
|
self.plugin.enforce_ratio = True
|
||||||
|
self.plugin.margin_percent = (500 - 490) / 500 * 1.5
|
||||||
|
self._assertImageIsValidArt(self.IMG_500x490, True)
|
Loading…
Reference in New Issue