gnu: coreutils: Skip racy 'tail' tests.
This works around <http://bugs.gnu.org/21460>. * gnu/packages/patches/coreutils-racy-tail-test.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/base.scm (coreutils): Use it.
This commit is contained in:
parent
b86c013c68
commit
895067ff49
|
@ -415,6 +415,7 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/clang-libc-search-path.patch \
|
gnu/packages/patches/clang-libc-search-path.patch \
|
||||||
gnu/packages/patches/clucene-pkgconfig.patch \
|
gnu/packages/patches/clucene-pkgconfig.patch \
|
||||||
gnu/packages/patches/cmake-fix-tests.patch \
|
gnu/packages/patches/cmake-fix-tests.patch \
|
||||||
|
gnu/packages/patches/coreutils-racy-tail-test.patch \
|
||||||
gnu/packages/patches/cpio-CVE-2014-9112-pt1.patch \
|
gnu/packages/patches/cpio-CVE-2014-9112-pt1.patch \
|
||||||
gnu/packages/patches/cpio-CVE-2014-9112-pt2.patch \
|
gnu/packages/patches/cpio-CVE-2014-9112-pt2.patch \
|
||||||
gnu/packages/patches/cpio-CVE-2014-9112-pt3.patch \
|
gnu/packages/patches/cpio-CVE-2014-9112-pt3.patch \
|
||||||
|
|
|
@ -248,7 +248,9 @@ used to apply commands with arbitrarily long arguments.")
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0w11jw3fb5sslf0f72kxy7llxgk1ia3a6bcw0c9kmvxrlj355mx2"))))
|
"0w11jw3fb5sslf0f72kxy7llxgk1ia3a6bcw0c9kmvxrlj355mx2"))
|
||||||
|
(patches
|
||||||
|
(list (search-patch "coreutils-racy-tail-test.patch")))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs `(("acl" ,acl) ; TODO: add SELinux
|
(inputs `(("acl" ,acl) ; TODO: add SELinux
|
||||||
("gmp" ,gmp) ;bignums in 'expr', yay!
|
("gmp" ,gmp) ;bignums in 'expr', yay!
|
||||||
|
|
|
@ -0,0 +1,13 @@
|
||||||
|
Skip this test, which uncovers a race condition in how 'tail' handles
|
||||||
|
file deletion. See <http://bugs.gnu.org/21460>.
|
||||||
|
|
||||||
|
--- a/tests/tail-2/assert.sh
|
||||||
|
+++ b/tests/tail-2/assert.sh
|
||||||
|
@@ -16,6 +16,7 @@
|
||||||
|
# You should have received a copy of the GNU General Public License
|
||||||
|
# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||||
|
|
||||||
|
+exit 77 # see <http://bugs.gnu.org/21460>
|
||||||
|
|
||||||
|
# This test fails with tail from textutils-2.0.
|
||||||
|
# It would get something like this:
|
Loading…
Reference in New Issue