gnu: guile-static-stripped: Adjust patches for 2.2.6.
* gnu/packages/patches/guile-2.2-default-utf8.patch, gnu/packages/patches/guile-relocatable.patch: Adjust for Guile 2.2.6.
This commit is contained in:
parent
1c94df8a1b
commit
8aaf42c037
|
@ -4,10 +4,10 @@ available during bootstrap, so using UTF-8 avoids that (and UTF-8 has
|
|||
built-in conversions in glibc, too.)
|
||||
|
||||
diff --git a/libguile/bytevectors.c b/libguile/bytevectors.c
|
||||
index 7cd753009..de92653a4 100644
|
||||
index 0ac5ea6a6..f73301e2f 100644
|
||||
--- a/libguile/bytevectors.c
|
||||
+++ b/libguile/bytevectors.c
|
||||
@@ -1918,7 +1918,7 @@ utf_encoding_name (char *name, size_t utf_width, SCM endianness)
|
||||
@@ -1931,7 +1931,7 @@ utf_encoding_name (char *name, size_t utf_width, SCM endianness)
|
||||
if (scm_i_is_narrow_string (str)) \
|
||||
{ \
|
||||
err = mem_iconveh (scm_i_string_chars (str), c_strlen, \
|
||||
|
@ -17,10 +17,10 @@ index 7cd753009..de92653a4 100644
|
|||
&c_utf, &c_utf_len); \
|
||||
if (SCM_UNLIKELY (err)) \
|
||||
diff --git a/libguile/ports.c b/libguile/ports.c
|
||||
index 2a25cd58e..bdaf921ca 100644
|
||||
index 45e62f4e4..42012f3aa 100644
|
||||
--- a/libguile/ports.c
|
||||
+++ b/libguile/ports.c
|
||||
@@ -959,7 +959,9 @@ canonicalize_encoding (const char *enc)
|
||||
@@ -974,7 +974,9 @@ canonicalize_encoding (const char *enc)
|
||||
char *ret;
|
||||
int i;
|
||||
|
||||
|
@ -31,7 +31,7 @@ index 2a25cd58e..bdaf921ca 100644
|
|||
return sym_ISO_8859_1;
|
||||
if (encoding_matches (enc, sym_UTF_8))
|
||||
return sym_UTF_8;
|
||||
@@ -4182,7 +4184,7 @@ scm_init_ports (void)
|
||||
@@ -4198,7 +4200,7 @@ scm_init_ports (void)
|
||||
scm_c_define ("%default-port-conversion-strategy",
|
||||
scm_make_fluid_with_default (sym_substitute));
|
||||
/* Use the locale as the default port encoding. */
|
||||
|
@ -41,10 +41,10 @@ index 2a25cd58e..bdaf921ca 100644
|
|||
scm_c_register_extension ("libguile-" SCM_EFFECTIVE_VERSION,
|
||||
"scm_init_ice_9_ports",
|
||||
diff --git a/libguile/strings.c b/libguile/strings.c
|
||||
index 5c49e33d8..0131e6dc8 100644
|
||||
index 056b4c99f..63a6c050d 100644
|
||||
--- a/libguile/strings.c
|
||||
+++ b/libguile/strings.c
|
||||
@@ -1561,7 +1561,7 @@ scm_i_default_string_failed_conversion_handler (void)
|
||||
@@ -1579,7 +1579,7 @@ scm_i_default_string_failed_conversion_handler (void)
|
||||
SCM
|
||||
scm_from_locale_stringn (const char *str, size_t len)
|
||||
{
|
||||
|
@ -53,7 +53,7 @@ index 5c49e33d8..0131e6dc8 100644
|
|||
scm_i_default_string_failed_conversion_handler ());
|
||||
}
|
||||
|
||||
@@ -1885,7 +1885,7 @@ char *
|
||||
@@ -1907,7 +1907,7 @@ char *
|
||||
scm_to_locale_stringn (SCM str, size_t *lenp)
|
||||
{
|
||||
return scm_to_stringn (str, lenp,
|
||||
|
@ -62,17 +62,21 @@ index 5c49e33d8..0131e6dc8 100644
|
|||
scm_i_default_string_failed_conversion_handler ());
|
||||
}
|
||||
|
||||
@@ -2216,11 +2216,11 @@ scm_to_stringn (SCM str, size_t *lenp, const char *encoding,
|
||||
len = 0;
|
||||
enc = encoding;
|
||||
if (enc == NULL)
|
||||
- enc = "ISO-8859-1";
|
||||
+ enc = "UTF-8";
|
||||
@@ -2195,7 +2195,7 @@ scm_to_stringn (SCM str, size_t *lenp, const char *encoding,
|
||||
scm_wrong_type_arg_msg (NULL, 0, str, "string");
|
||||
|
||||
if (encoding == NULL)
|
||||
- encoding = "ISO-8859-1";
|
||||
+ encoding = "UTF-8";
|
||||
|
||||
if (c_strcasecmp (encoding, "UTF-8") == 0)
|
||||
/* This is the most common case--e.g., when calling libc bindings
|
||||
@@ -2247,7 +2247,7 @@ scm_to_stringn (SCM str, size_t *lenp, const char *encoding,
|
||||
if (scm_i_is_narrow_string (str))
|
||||
{
|
||||
ret = mem_iconveh (scm_i_string_chars (str), ilen,
|
||||
- "ISO-8859-1", enc,
|
||||
+ "UTF-8", enc,
|
||||
- "ISO-8859-1", encoding,
|
||||
+ "UTF-8", encoding,
|
||||
(enum iconv_ilseq_handler) handler, NULL,
|
||||
&buf, &len);
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ location of the `guile' binary, allowing it to be relocated.
|
|||
|
||||
#include "libguile/_scm.h"
|
||||
#include "libguile/alist.h"
|
||||
@@ -325,6 +326,32 @@
|
||||
@@ -326,6 +327,32 @@ scm_init_load_path ()
|
||||
SCM cpath = SCM_EOL;
|
||||
|
||||
#ifdef SCM_LIBRARY_DIR
|
||||
|
@ -44,24 +44,24 @@ location of the `guile' binary, allowing it to be relocated.
|
|||
env = scm_i_mirror_backslashes (getenv ("GUILE_SYSTEM_PATH"));
|
||||
if (env && strcmp (env, "") == 0)
|
||||
/* special-case interpret system-path=="" as meaning no system path instead
|
||||
@@ -333,10 +360,7 @@
|
||||
@@ -334,10 +361,7 @@ scm_init_load_path ()
|
||||
else if (env)
|
||||
path = scm_parse_path (scm_from_locale_string (env), path);
|
||||
else
|
||||
- path = scm_list_4 (scm_from_locale_string (SCM_LIBRARY_DIR),
|
||||
- scm_from_locale_string (SCM_SITE_DIR),
|
||||
- scm_from_locale_string (SCM_GLOBAL_SITE_DIR),
|
||||
- scm_from_locale_string (SCM_PKGDATA_DIR));
|
||||
- path = scm_list_4 (scm_from_utf8_string (SCM_LIBRARY_DIR),
|
||||
- scm_from_utf8_string (SCM_SITE_DIR),
|
||||
- scm_from_utf8_string (SCM_GLOBAL_SITE_DIR),
|
||||
- scm_from_utf8_string (SCM_PKGDATA_DIR));
|
||||
+ path = scm_list_1 (scm_from_locale_string (module_dir));
|
||||
|
||||
env = scm_i_mirror_backslashes (getenv ("GUILE_SYSTEM_COMPILED_PATH"));
|
||||
if (env && strcmp (env, "") == 0)
|
||||
@@ -346,8 +370,7 @@
|
||||
@@ -347,8 +371,7 @@ scm_init_load_path ()
|
||||
cpath = scm_parse_path (scm_from_locale_string (env), cpath);
|
||||
else
|
||||
{
|
||||
- cpath = scm_list_2 (scm_from_locale_string (SCM_CCACHE_DIR),
|
||||
- scm_from_locale_string (SCM_SITE_CCACHE_DIR));
|
||||
- cpath = scm_list_2 (scm_from_utf8_string (SCM_CCACHE_DIR),
|
||||
- scm_from_utf8_string (SCM_SITE_CCACHE_DIR));
|
||||
+ cpath = scm_list_1 (scm_from_locale_string (ccache_dir));
|
||||
}
|
||||
|
||||
|
|
Loading…
Reference in New Issue