gnu: WebKitGTK: Update to 2.24.3.
* gnu/packages/webkit.scm (webkitgtk-2.24): Update to 2.24.3. [source](patches): Remove. * gnu/packages/patches/webkitgtk-sans-gstreamer-gl.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
f62b57ba74
commit
8b5df106fd
|
@ -1370,7 +1370,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/wavpack-CVE-2018-6767.patch \
|
||||
%D%/packages/patches/wavpack-CVE-2018-7253.patch \
|
||||
%D%/packages/patches/wavpack-CVE-2018-7254.patch \
|
||||
%D%/packages/patches/webkitgtk-sans-gstreamer-gl.patch \
|
||||
%D%/packages/patches/weechat-python.patch \
|
||||
%D%/packages/patches/wicd-bitrate-none-fix.patch \
|
||||
%D%/packages/patches/wicd-get-selected-profile-fix.patch \
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
Fix build failure when USE_GSTREAMER_GL=off. See
|
||||
<https://bugs.webkit.org/show_bug.cgi?id=196440>.
|
||||
|
||||
This patch is taken from the upstream source repository:
|
||||
<https://git.webkit.org/?p=WebKit.git;a=commitdiff;h=e2dd6decbe25ea9498f1ba213808f34b232740c7>.
|
||||
|
||||
diff --git a/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp b/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp
|
||||
index 00a2af6489e..5cb5f7536ac 100644
|
||||
--- a/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp
|
||||
+++ b/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp
|
||||
@@ -1000,11 +1000,13 @@ void MediaPlayerPrivateGStreamerBase::updateTextureMapperFlags()
|
||||
break;
|
||||
}
|
||||
|
||||
+#if USE(GSTREAMER_GL)
|
||||
// When the imxvpudecoder is used, the texture sampling of the
|
||||
// directviv-uploaded texture returns an RGB value, so there's no need to
|
||||
// convert it.
|
||||
if (m_videoDecoderPlatform != WebKitGstVideoDecoderPlatform::ImxVPU)
|
||||
m_textureMapperFlags |= TEXTURE_MAPPER_COLOR_CONVERT_FLAG;
|
||||
+#endif
|
||||
}
|
||||
#endif
|
||||
|
|
@ -168,15 +168,14 @@ HTML/CSS applications to full-fledged web browsers.")
|
|||
(define-public webkitgtk-2.24
|
||||
(package/inherit webkitgtk
|
||||
(name "webkitgtk")
|
||||
(version "2.24.2")
|
||||
(version "2.24.3")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://www.webkitgtk.org/releases/"
|
||||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"071jnjvjq6wsxx1jh4ql3j53h1nhphs5ga67fa5i9xjvs3qb3701"))
|
||||
(patches (search-patches "webkitgtk-sans-gstreamer-gl.patch"))))
|
||||
"0lbcrw5axwrbrajxq7fqywfyh0djqi23ynzb5wi5ghw2grnp83cl"))))
|
||||
(native-inputs
|
||||
`(("gcc" ,gcc-7) ; webkitgtk-2.22 requires gcc-6 or newer
|
||||
,@(package-native-inputs webkitgtk)))
|
||||
|
|
Loading…
Reference in New Issue