gnu: blast+: Update to 2.7.1.
* gnu/packages/bioinformatics.scm (blast+): Update to 2.7.1. [inputs]: Add lmdb. [source]: Remove obsolete patch. * gnu/package/patches/blast+-fix-makefile.patch: Remove patch. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
f87dcb4d75
commit
8b6acb1f20
|
@ -670,7 +670,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/beignet-correct-file-names.patch \
|
||||
%D%/packages/patches/biber-fix-encoding-write.patch \
|
||||
%D%/packages/patches/binutils-loongson-workaround.patch \
|
||||
%D%/packages/patches/blast+-fix-makefile.patch \
|
||||
%D%/packages/patches/boost-fix-icu-build.patch \
|
||||
%D%/packages/patches/byobu-writable-status.patch \
|
||||
%D%/packages/patches/calibre-no-updates-dialog.patch \
|
||||
|
|
|
@ -1092,7 +1092,7 @@ package provides command line tools using the Bio++ library.")
|
|||
(define-public blast+
|
||||
(package
|
||||
(name "blast+")
|
||||
(version "2.6.0")
|
||||
(version "2.7.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
|
@ -1100,8 +1100,7 @@ package provides command line tools using the Bio++ library.")
|
|||
version "/ncbi-blast-" version "+-src.tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"15n937pw5aqmyfjb6l387d18grqbb96l63d5xj4l7yyh0zbf2405"))
|
||||
(patches (search-patches "blast+-fix-makefile.patch"))
|
||||
"1jlq0afxxgczpp35k6mxh8mn4jzq7vqcnaixk166sfj10wq8v9qh"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
|
@ -1209,6 +1208,7 @@ package provides command line tools using the Bio++ library.")
|
|||
"include")) ; 33 MB
|
||||
(inputs
|
||||
`(("bzip2" ,bzip2)
|
||||
("lmdb" ,lmdb)
|
||||
("zlib" ,zlib)
|
||||
("pcre" ,pcre)
|
||||
("perl" ,perl)
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
Without this patch, the 'make install' attempts to 'install' a directory, which causes an error.
|
||||
|
||||
diff --git a/c++/src/build-system/Makefile.in.top b/c++/src/build-system/Makefile.in.top
|
||||
index 1abe44f..d6000b3 100644
|
||||
--- a/c++/src/build-system/Makefile.in.top
|
||||
+++ b/c++/src/build-system/Makefile.in.top
|
||||
@@ -51,7 +51,7 @@ install-toolkit:
|
||||
done
|
||||
cd $(includedir0) && find * -name CVS -prune -o -print |\
|
||||
cpio -pd $(pincludedir)
|
||||
- $(INSTALL) -m 644 $(incdir)/* $(pincludedir)
|
||||
+ cp -R $(incdir)/* $(pincludedir)
|
||||
## set up appropriate build and status directories somewhere under $(libdir)?
|
||||
|
||||
install-gbench:
|
Loading…
Reference in New Issue