gnu: icu4c: Update to 54.1.
* gnu/packages/icu4c.scm (icu4c): Update to 54.1. * gnu/packages/patches/icu4c-test-date-format.patch: Remove unneeded patch. * gnu-system.am (dist_patch_DATA): Unregister dropped patch.
This commit is contained in:
parent
a4d8913613
commit
8c3fc83411
|
@ -366,7 +366,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/guix-test-networking.patch \
|
||||
gnu/packages/patches/gtkglext-disable-disable-deprecated.patch \
|
||||
gnu/packages/patches/hop-bigloo-4.0b.patch \
|
||||
gnu/packages/patches/icu4c-test-date-format.patch \
|
||||
gnu/packages/patches/inkscape-stray-comma.patch \
|
||||
gnu/packages/patches/jbig2dec-ignore-testtest.patch \
|
||||
gnu/packages/patches/kmod-module-directory.patch \
|
||||
|
|
|
@ -28,7 +28,7 @@
|
|||
(define-public icu4c
|
||||
(package
|
||||
(name "icu4c")
|
||||
(version "53.1")
|
||||
(version "54.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "http://download.icu-project.org/files/icu4c/"
|
||||
|
@ -37,8 +37,7 @@
|
|||
(string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
|
||||
"-src.tgz"))
|
||||
(sha256
|
||||
(base32 "0a4sg9w054640zncb13lhrcjqn7yg1qilwd1mczc4w60maslz9vg"))
|
||||
(patches (list (search-patch "icu4c-test-date-format.patch")))))
|
||||
(base32 "1cwapgjmvrcv1n2wjspj3vahidg596gjfp4jn1gcb4baralcjayl"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
`(("patchelf" ,patchelf)
|
||||
|
@ -59,7 +58,7 @@
|
|||
'configure 'patch-configure
|
||||
(lambda _
|
||||
;; patch out two occurrences of /bin/sh from configure script
|
||||
;; that might have disappeared in a release later than 52.1
|
||||
;; that might have disappeared in a release later than 54.1
|
||||
(substitute* "configure"
|
||||
(("`/bin/sh")
|
||||
(string-append "`" (which "bash")))))
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
Starting with the switch to GCC 4.8.3, we observed this test failure.
|
||||
Changing "34" to "134" means that we expect the date to be parsed as
|
||||
"2034", not "1934", which seems consistent with the line above.
|
||||
|
||||
Reported at <http://bugs.icu-project.org/trac/ticket/10960>.
|
||||
|
||||
--- icu/source/test/intltest/dtfmttst.cpp 2014-06-16 10:35:46.000000000 +0200
|
||||
+++ icu/source/test/intltest/dtfmttst.cpp 2014-06-16 10:35:52.000000000 +0200
|
||||
@@ -1129,7 +1129,7 @@ DateFormatTest::TestTwoDigitYear()
|
||||
return;
|
||||
}
|
||||
parse2DigitYear(fmt, "5/6/17", date(117, UCAL_JUNE, 5));
|
||||
- parse2DigitYear(fmt, "4/6/34", date(34, UCAL_JUNE, 4));
|
||||
+ parse2DigitYear(fmt, "4/6/34", date(134, UCAL_JUNE, 4));
|
||||
}
|
||||
|
||||
// -------------------------------------
|
Loading…
Reference in New Issue