gnu: gdk-pixbuf: Make it reproducible.

Fixes <http://bugs.gnu.org/25414>.

* gnu/packages/gtk.scm (gdk-pixbuf)[source](patches): New field.
master
Danny Milosavljevic 2017-01-16 16:27:51 +01:00
parent b09903619f
commit 8c6b077bfa
No known key found for this signature in database
GPG Key ID: E71A35542C30BAA5
3 changed files with 38 additions and 1 deletions

View File

@ -568,6 +568,7 @@ dist_patch_DATA = \
%D%/packages/patches/gcc-6-arm-none-eabi-multilib.patch \
%D%/packages/patches/gcc-6-cross-environment-variables.patch \
%D%/packages/patches/gcj-arm-mode.patch \
%D%/packages/patches/gdk-pixbuf-list-dir.patch \
%D%/packages/patches/gd-CVE-2016-7568.patch \
%D%/packages/patches/gd-CVE-2016-8670.patch \
%D%/packages/patches/gd-fix-chunk-size-on-boundaries.patch \

View File

@ -433,7 +433,8 @@ highlighting and other features typical of a source code editor.")
name "-" version ".tar.xz"))
(sha256
(base32
"1v1rssjd8p5s3lymsfhiq5mbs2pc0h1r6jd0asrwdbrign7i68sj"))))
"1v1rssjd8p5s3lymsfhiq5mbs2pc0h1r6jd0asrwdbrign7i68sj"))
(patches (search-patches "gdk-pixbuf-list-dir.patch"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--with-x11")

View File

@ -0,0 +1,35 @@
Sort directory entries so that the output of
gdk-pixbuf-query-loaders is deterministic.
See: https://bugzilla.gnome.org/show_bug.cgi?id=777332
--- gdk-pixbuf-2.34.0/gdk-pixbuf/queryloaders.c.orig 2017-01-11 00:17:32.865843062 +0100
+++ gdk-pixbuf-2.34.0/gdk-pixbuf/queryloaders.c 2017-01-16 16:12:03.420667874 +0100
@@ -354,16 +354,27 @@
dir = g_dir_open (path, 0, NULL);
if (dir) {
+ GList *entries = NULL;
const char *dent;
while ((dent = g_dir_read_name (dir))) {
gint len = strlen (dent);
if (len > SOEXT_LEN &&
strcmp (dent + len - SOEXT_LEN, SOEXT) == 0) {
- query_module (contents, path, dent);
+ entries = g_list_append (entries, g_strdup (dent));
}
}
g_dir_close (dir);
+ /* Sort directory entries so that the output of
+ gdk-pixbuf-query-loaders is deterministic. */
+ entries = g_list_sort (entries, (GCompareFunc) strcmp);
+ GList *xentries;
+ for (xentries = entries; xentries; xentries = g_list_next (xentries)) {
+ dent = xentries->data;
+ query_module (contents, path, dent);
+ g_free (xentries->data);
+ }
+ g_list_free (entries);
}
#else
g_string_append_printf (contents, "# dynamic loading of modules not supported\n");