gnu: parted: Fix build with glibc >= 2.28.
* gnu/packages/patches/parted-glibc-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/disk.scm (parted)[source](patches): New field.
This commit is contained in:
parent
60ecc10f18
commit
8d48f358e9
|
@ -1009,6 +1009,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/p7zip-CVE-2016-9296.patch \
|
%D%/packages/patches/p7zip-CVE-2016-9296.patch \
|
||||||
%D%/packages/patches/p7zip-CVE-2017-17969.patch \
|
%D%/packages/patches/p7zip-CVE-2017-17969.patch \
|
||||||
%D%/packages/patches/p7zip-remove-unused-code.patch \
|
%D%/packages/patches/p7zip-remove-unused-code.patch \
|
||||||
|
%D%/packages/patches/parted-glibc-compat.patch \
|
||||||
%D%/packages/patches/patchelf-page-size.patch \
|
%D%/packages/patches/patchelf-page-size.patch \
|
||||||
%D%/packages/patches/patchelf-rework-for-arm.patch \
|
%D%/packages/patches/patchelf-rework-for-arm.patch \
|
||||||
%D%/packages/patches/patchutils-xfail-gendiff-tests.patch \
|
%D%/packages/patches/patchutils-xfail-gendiff-tests.patch \
|
||||||
|
|
|
@ -76,6 +76,7 @@
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/parted/parted-"
|
(uri (string-append "mirror://gnu/parted/parted-"
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
|
(patches (search-patches "parted-glibc-compat.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1r3qpg3bhz37mgvp9chsaa3k0csby3vayfvz8ggsqz194af5i2w5"))))
|
"1r3qpg3bhz37mgvp9chsaa3k0csby3vayfvz8ggsqz194af5i2w5"))))
|
||||||
|
|
|
@ -0,0 +1,17 @@
|
||||||
|
Include <sys/sysmacros.h> for "major" and "minor".
|
||||||
|
|
||||||
|
Taken from upstream:
|
||||||
|
https://git.savannah.gnu.org/cgit/parted.git/commit/?id=ba5e0451b51c983e40afd123b6e0d3eddb55e610
|
||||||
|
|
||||||
|
diff --git a/libparted/arch/linux.c b/libparted/arch/linux.c
|
||||||
|
index 31b98ab..7e86b51 100644
|
||||||
|
--- a/libparted/arch/linux.c
|
||||||
|
+++ b/libparted/arch/linux.c
|
||||||
|
@@ -41,6 +41,7 @@
|
||||||
|
#include <sys/utsname.h> /* for uname() */
|
||||||
|
#include <scsi/scsi.h>
|
||||||
|
#include <assert.h>
|
||||||
|
+#include <sys/sysmacros.h>
|
||||||
|
#ifdef ENABLE_DEVICE_MAPPER
|
||||||
|
#include <libdevmapper.h>
|
||||||
|
#endif
|
Loading…
Reference in New Issue