gnu: Add perl-net-dns-resolver-programmable.

* gnu/packages/networking.scm (perl-net-dns-resolver-programmable): New variable.
* gnu/packages/patches/perl-net-dns-resolver-programmable-Fix-broken-interface.patch:
New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Leo Famulari <leo@famulari.name>
master
Danny Milosavljevic 2016-07-28 23:38:20 +02:00 committed by Leo Famulari
parent 87b1409140
commit 8d60dd7174
No known key found for this signature in database
GPG Key ID: 2646FA30BACA7F08
3 changed files with 60 additions and 0 deletions

View File

@ -704,6 +704,7 @@ dist_patch_DATA = \
%D%/packages/patches/perl-io-socket-ssl-openssl-1.0.2f-fix.patch \
%D%/packages/patches/perl-net-amazon-s3-moose-warning.patch \
%D%/packages/patches/perl-net-ssleay-disable-ede-test.patch \
%D%/packages/patches/perl-net-dns-resolver-programmable-Fix-broken-interface.patch \
%D%/packages/patches/perl-no-build-time.patch \
%D%/packages/patches/perl-no-sys-dirs.patch \
%D%/packages/patches/perl-module-pluggable-search.patch \

View File

@ -30,6 +30,7 @@
#:use-module (guix download)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages adns)
#:use-module (gnu packages algebra)
@ -469,3 +470,31 @@ application stack itself.")
(description "Socket6 binds the IPv6 related part of the C socket header
definitions and structure manipulators for Perl.")
(license license:bsd-3)))
(define-public perl-net-dns-resolver-programmable
(package
(name "perl-net-dns-resolver-programmable")
(version "v0.003")
(source
(origin
(method url-fetch)
(uri (string-append
"mirror://cpan/authors/id/J/JM/JMEHNLE/net-dns-resolver-programmable/"
"Net-DNS-Resolver-Programmable-" version ".tar.gz"))
(sha256
(base32
"1v3nl2kaj4fs55n1617n53q8sa3mir06898vpy1rq98zjih24h4d"))
(patches
(search-patches
"perl-net-dns-resolver-programmable-Fix-broken-interface.patch"))))
(build-system perl-build-system)
(native-inputs
`(("perl-module-build" ,perl-module-build)))
(inputs `(("perl-net-dns" ,perl-net-dns)))
(home-page
"http://search.cpan.org/dist/Net-DNS-Resolver-Programmable")
(synopsis
"Programmable DNS resolver class for offline emulation of DNS")
(description "Net::DNS::Resolver::Programmable is a programmable DNS resolver for
offline emulation of DNS.")
(license (package-license perl))))

View File

@ -0,0 +1,30 @@
perl-net-dns-resolver-programmable used the undocumented and internal
method Net::DNS::rcodesbyname [0], and that interface is no longer
exposed.
This patch, copied from [1], makes the program check for the existence
of the method before trying to use it.
[0]
<https://rt.cpan.org/Public/Bug/Display.html?id=95901>
[1]
<https://rt.cpan.org/Public/Bug/Display.html?id=95901#txn-1575108>
diff --git a/lib/Net/DNS/Resolver/Programmable.pm b/lib/Net/DNS/Resolver/Programmable.pm
index 1af72ce..e09a2f0 100644
--- a/lib/Net/DNS/Resolver/Programmable.pm
+++ b/lib/Net/DNS/Resolver/Programmable.pm
@@ -203,8 +203,10 @@ sub send {
if (defined(my $resolver_code = $self->{resolver_code})) {
($result, $aa, @answer_rrs) = $resolver_code->($domain, $rr_type, $class);
}
-
- if (not defined($result) or defined($Net::DNS::rcodesbyname{$result})) {
+
+ if (not defined($result)
+ or defined($Net::DNS::Parameters::rcodebyname{$result})
+ or defined($Net::DNS::rcodesbyname{$result})) {
# Valid RCODE, return a packet:
$aa = TRUE if not defined($aa);