gnu: libgnomeui: Fix build with Python 3.6.

* gnu/packages/patches/libgnomeui-utf8.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/gnome.scm (libgnomeui)[source]: Use it.
master
Leo Famulari 2018-01-16 13:43:38 -08:00
parent ae307724de
commit 8fa1872aba
No known key found for this signature in database
GPG Key ID: 2646FA30BACA7F08
3 changed files with 53 additions and 0 deletions

View File

@ -815,6 +815,7 @@ dist_patch_DATA = \
%D%/packages/patches/libgdata-fix-tests.patch \
%D%/packages/patches/libgdata-glib-duplicate-tests.patch \
%D%/packages/patches/libgnome-encoding.patch \
%D%/packages/patches/libgnomeui-utf8.patch \
%D%/packages/patches/libgxps-CVE-2017-11590.patch \
%D%/packages/patches/libffi-3.2.1-complex-alpha.patch \
%D%/packages/patches/libjxr-fix-function-signature.patch \

View File

@ -1601,6 +1601,7 @@ creating interactive structured graphics.")
(uri (string-append "mirror://gnome/sources/" name "/"
(version-major+minor version) "/"
name "-" version ".tar.bz2"))
(patches (search-patches "libgnomeui-utf8.patch"))
(sha256
(base32
"03rwbli76crkjl6gp422wrc9lqpl174k56cp9i96b7l8jlj2yddf"))))

View File

@ -0,0 +1,51 @@
Fixes build with Python >= 3.6:
------
Making all in libgnomeui
make[2]: Entering directory '/tmp/guix-build-libgnomeui-2.24.5.drv-0/libgnomeui-2.24.5/libgnomeui'
GEN stamp-gnome-marshal.h
GEN stamp-gnometypebuiltins.h
INFO: Reading ./gnome-marshal.list...
GEN gnome-marshal.h
Traceback (most recent call last):
File "/gnu/store/azh1is0xknn4xphwj33iqcb5ic9qhk8l-glib-2.54.2-bin/bin/glib-mkenums", line 688, in <module>
process_file(fname)
File "/gnu/store/azh1is0xknn4xphwj33iqcb5ic9qhk8l-glib-2.54.2-bin/bin/glib-mkenums", line 420, in process_file
line = curfile.readline()
File "/gnu/store/3lkypf5wnsnvkaidhw0pv7k3yjfh1r9g-python-3.6.3/lib/python3.6/codecs.py", line 321, in decode
(result, consumed) = self._buffer_decode(data, self.errors, final)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf1 in position 1009: invalid continuation byte
make[2]: *** [Makefile:1109: stamp-gnometypebuiltins.h] Error 1
make[2]: Leaving directory '/tmp/guix-build-libgnomeui-2.24.5.drv-0/libgnomeui-2.24.5/libgnomeui'
make[1]: *** [Makefile:369: all-recursive] Error 1
make[1]: Leaving directory '/tmp/guix-build-libgnomeui-2.24.5.drv-0/libgnomeui-2.24.5'
make: *** [Makefile:296: all] Error 2
------
Patch copied from upstream source repository:
https://git.gnome.org/browse/libgnomeui/commit/?id=30334c28794ef85d8973f4ed0779b5ceed6594f2
From 30334c28794ef85d8973f4ed0779b5ceed6594f2 Mon Sep 17 00:00:00 2001
From: Colin Walters <walters@verbum.org>
Date: Mon, 7 Aug 2017 13:15:26 -0400
Subject: [PATCH] gnome-scores.h: Convert to UTF-8
The new Python `glib-mkenums` barfs on ISO-8859-1 input.
---
libgnomeui/gnome-scores.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libgnomeui/gnome-scores.h b/libgnomeui/gnome-scores.h
index 911b12d1..4e641d22 100644
--- a/libgnomeui/gnome-scores.h
+++ b/libgnomeui/gnome-scores.h
@@ -27,7 +27,7 @@
* "High Scores" Widget
*
* AUTHOR:
- * Horacio J. Peña <horape@compendium.com.ar>
+ * Horacio J. Peña <horape@compendium.com.ar>
*
* This is free software (under the terms of the GNU LGPL)
*