gnu: luajit: Update to 2.1.0-beta3.
* gnu/packages/lua.scm (luajit): Update to 2.1.0-beta3. [source]: Remove symlinks patch. * gnu/packages/patches/luajit-symlinks.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
b2d00af723
commit
906f1b48e2
|
@ -891,7 +891,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/lua51-pkgconfig.patch \
|
||||
%D%/packages/patches/lua-liblua-so.patch \
|
||||
%D%/packages/patches/luajit-no_ldconfig.patch \
|
||||
%D%/packages/patches/luajit-symlinks.patch \
|
||||
%D%/packages/patches/luit-posix.patch \
|
||||
%D%/packages/patches/luminance-hdr-qt-printer.patch \
|
||||
%D%/packages/patches/lvm2-static-link.patch \
|
||||
|
|
|
@ -8,6 +8,7 @@
|
|||
;;; Copyright © 2016 doncatnip <gnopap@gmail.com>
|
||||
;;; Copyright © 2016, 2017 Clément Lassieur <clement@lassieur.org>
|
||||
;;; Copyright © 2016 José Miguel Sánchez García <jmi2k@openmailbox.org>
|
||||
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
|
@ -116,15 +117,14 @@ for configuration, scripting, and rapid prototyping.")
|
|||
(define-public luajit
|
||||
(package
|
||||
(name "luajit")
|
||||
(version "2.1.0-beta2")
|
||||
(version "2.1.0-beta3")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "http://luajit.org/download/LuaJIT-"
|
||||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32 "0iyghj1xjlmd9ywa4flf9yszynf3jhbp0yqb9b49k7ab0g528fbi"))
|
||||
(patches (search-patches "luajit-symlinks.patch"
|
||||
"luajit-no_ldconfig.patch"))))
|
||||
(base32 "1hyrhpkwjqsv54hnnx4cl8vk44h9d6c9w0fz1jfjz00w255y7lhs"))
|
||||
(patches (search-patches "luajit-no_ldconfig.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:tests? #f ;luajit is distributed without tests
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
From 0a54a8f125d7ab508c7c88d5ad4ed1b0c63cb5b6 Mon Sep 17 00:00:00 2001
|
||||
From: =?utf8?q?Tom=C3=A1=C5=A1=20=C4=8Cech?= <sleep_walker@suse.cz>
|
||||
Date: Wed, 4 Feb 2015 11:32:55 +0100
|
||||
Subject: [PATCH 1/2] Provide two symlinks for dynamic library during install
|
||||
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 0891b71..343ecb5 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -56,7 +56,7 @@ INSTALL_PCNAME= luajit.pc
|
||||
INSTALL_STATIC= $(INSTALL_LIB)/$(INSTALL_ANAME)
|
||||
INSTALL_DYN= $(INSTALL_LIB)/$(INSTALL_SONAME)
|
||||
INSTALL_SHORT1= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
|
||||
-INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
|
||||
+INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT).$(MAJVER)
|
||||
INSTALL_T= $(INSTALL_BIN)/$(INSTALL_TNAME)
|
||||
INSTALL_TSYM= $(INSTALL_BIN)/$(INSTALL_TSYMNAME)
|
||||
INSTALL_PC= $(INSTALL_PKGCONFIG)/$(INSTALL_PCNAME)
|
||||
--
|
||||
2.2.2
|
||||
|
Loading…
Reference in New Issue