gnu: r: Apply patch to fix linking against R.

* gnu/packages/patches/r-fix-15899.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/statistics.scm (r)[source]: Use it.
master
Ricardo Wurmus 2015-05-19 11:53:47 +02:00
parent afb925175e
commit 9099e88182
3 changed files with 20 additions and 1 deletions

View File

@ -542,6 +542,7 @@ dist_patch_DATA = \
gnu/packages/patches/qt4-tests.patch \
gnu/packages/patches/qt5-conflicting-typedefs.patch \
gnu/packages/patches/qt5-runpath.patch \
gnu/packages/patches/r-fix-15899.patch \
gnu/packages/patches/ratpoison-shell.patch \
gnu/packages/patches/readline-link-ncurses.patch \
gnu/packages/patches/ripperx-libm.patch \

View File

@ -0,0 +1,17 @@
Without the "extern" keyword external applications linking against R (such as
Shogun, for example) might not be linkable.
See https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=15899 for details
about this bug.
--- a/src/include/Rinterface.h (revision 66251)
+++ b/src/include/Rinterface.h (working copy)
@@ -84,7 +84,7 @@
void fpu_setup(Rboolean);
/* in unix/system.c */
-int R_running_as_main_program;
+extern int R_running_as_main_program;
#ifdef CSTACK_DEFNS
/* duplicating Defn.h */

View File

@ -50,7 +50,8 @@
version ".tar.gz"))
(sha256
(base32
"0dagyqgvi8i3nw158qi2zpwm04s4ffzvnmk5niaksvxs30zrbbpm"))))
"0dagyqgvi8i3nw158qi2zpwm04s4ffzvnmk5niaksvxs30zrbbpm"))
(patches (list (search-patch "r-fix-15899.patch")))))
(build-system gnu-build-system)
(arguments
`(#:make-flags