gnu: python: Fix CVE-2018-14647.
* gnu/packages/patches/python-CVE-2018-14647.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/python.scm (python-3/fixed): New variable. (python-3.6)[replacement]: New field. (python-minimal, python-debug, wrap-python3): Use PACKAGE/INHERIT instead of standard inheritance.
This commit is contained in:
parent
1d43756107
commit
90aeaee861
|
@ -1076,6 +1076,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/python-3-deterministic-build-info.patch \
|
%D%/packages/patches/python-3-deterministic-build-info.patch \
|
||||||
%D%/packages/patches/python-3-search-paths.patch \
|
%D%/packages/patches/python-3-search-paths.patch \
|
||||||
%D%/packages/patches/python-3-fix-tests.patch \
|
%D%/packages/patches/python-3-fix-tests.patch \
|
||||||
|
%D%/packages/patches/python-CVE-2018-14647.patch \
|
||||||
%D%/packages/patches/python-axolotl-AES-fix.patch \
|
%D%/packages/patches/python-axolotl-AES-fix.patch \
|
||||||
%D%/packages/patches/python-cairocffi-dlopen-path.patch \
|
%D%/packages/patches/python-cairocffi-dlopen-path.patch \
|
||||||
%D%/packages/patches/python-fix-tests.patch \
|
%D%/packages/patches/python-fix-tests.patch \
|
||||||
|
|
|
@ -0,0 +1,61 @@
|
||||||
|
Fix CVE-2018-14647:
|
||||||
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-14647
|
||||||
|
https://bugs.python.org/issue34623
|
||||||
|
|
||||||
|
Taken from upstream:
|
||||||
|
https://github.com/python/cpython/commit/f7666e828cc3d5873136473ea36ba2013d624fa1
|
||||||
|
|
||||||
|
diff --git Include/pyexpat.h Include/pyexpat.h
|
||||||
|
index 44259bf6d7..07020b5dc9 100644
|
||||||
|
--- Include/pyexpat.h
|
||||||
|
+++ Include/pyexpat.h
|
||||||
|
@@ -3,7 +3,7 @@
|
||||||
|
|
||||||
|
/* note: you must import expat.h before importing this module! */
|
||||||
|
|
||||||
|
-#define PyExpat_CAPI_MAGIC "pyexpat.expat_CAPI 1.0"
|
||||||
|
+#define PyExpat_CAPI_MAGIC "pyexpat.expat_CAPI 1.1"
|
||||||
|
#define PyExpat_CAPSULE_NAME "pyexpat.expat_CAPI"
|
||||||
|
|
||||||
|
struct PyExpat_CAPI
|
||||||
|
@@ -48,6 +48,8 @@ struct PyExpat_CAPI
|
||||||
|
enum XML_Status (*SetEncoding)(XML_Parser parser, const XML_Char *encoding);
|
||||||
|
int (*DefaultUnknownEncodingHandler)(
|
||||||
|
void *encodingHandlerData, const XML_Char *name, XML_Encoding *info);
|
||||||
|
+ /* might be none for expat < 2.1.0 */
|
||||||
|
+ int (*SetHashSalt)(XML_Parser parser, unsigned long hash_salt);
|
||||||
|
/* always add new stuff to the end! */
|
||||||
|
};
|
||||||
|
|
||||||
|
diff --git Modules/_elementtree.c Modules/_elementtree.c
|
||||||
|
index 707ab2912b..53f05f937f 100644
|
||||||
|
--- Modules/_elementtree.c
|
||||||
|
+++ Modules/_elementtree.c
|
||||||
|
@@ -3261,6 +3261,11 @@ _elementtree_XMLParser___init___impl(XMLParserObject *self, PyObject *html,
|
||||||
|
PyErr_NoMemory();
|
||||||
|
return -1;
|
||||||
|
}
|
||||||
|
+ /* expat < 2.1.0 has no XML_SetHashSalt() */
|
||||||
|
+ if (EXPAT(SetHashSalt) != NULL) {
|
||||||
|
+ EXPAT(SetHashSalt)(self->parser,
|
||||||
|
+ (unsigned long)_Py_HashSecret.expat.hashsalt);
|
||||||
|
+ }
|
||||||
|
|
||||||
|
if (target) {
|
||||||
|
Py_INCREF(target);
|
||||||
|
diff --git Modules/pyexpat.c Modules/pyexpat.c
|
||||||
|
index 47c3e86c20..aa21d93c11 100644
|
||||||
|
--- Modules/pyexpat.c
|
||||||
|
+++ Modules/pyexpat.c
|
||||||
|
@@ -1887,6 +1887,11 @@ MODULE_INITFUNC(void)
|
||||||
|
capi.SetStartDoctypeDeclHandler = XML_SetStartDoctypeDeclHandler;
|
||||||
|
capi.SetEncoding = XML_SetEncoding;
|
||||||
|
capi.DefaultUnknownEncodingHandler = PyUnknownEncodingHandler;
|
||||||
|
+#if XML_COMBINED_VERSION >= 20100
|
||||||
|
+ capi.SetHashSalt = XML_SetHashSalt;
|
||||||
|
+#else
|
||||||
|
+ capi.SetHashSalt = NULL;
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
/* export using capsule */
|
||||||
|
capi_object = PyCapsule_New(&capi, PyExpat_CAPSULE_NAME, NULL);
|
|
@ -357,6 +357,7 @@ data types.")
|
||||||
(package (inherit python-2)
|
(package (inherit python-2)
|
||||||
(name "python")
|
(name "python")
|
||||||
(version "3.6.5")
|
(version "3.6.5")
|
||||||
|
(replacement python-3/fixed)
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://www.python.org/ftp/python/"
|
(uri (string-append "https://www.python.org/ftp/python/"
|
||||||
|
@ -456,6 +457,24 @@ data types.")
|
||||||
;; Current 3.x version.
|
;; Current 3.x version.
|
||||||
(define-public python-3 python-3.6)
|
(define-public python-3 python-3.6)
|
||||||
|
|
||||||
|
(define python-3/fixed
|
||||||
|
(package
|
||||||
|
(inherit python-3)
|
||||||
|
(source (origin
|
||||||
|
(inherit (package-source python-3))
|
||||||
|
(patches (append (origin-patches (package-source python-3))
|
||||||
|
(search-patches "python-CVE-2018-14647.patch")))))
|
||||||
|
(arguments
|
||||||
|
(substitute-keyword-arguments (package-arguments python-3)
|
||||||
|
((#:phases phases)
|
||||||
|
`(modify-phases ,phases
|
||||||
|
(add-after 'unpack 'delete-broken-test
|
||||||
|
(lambda _
|
||||||
|
;; Delete test which fails on recent kernels:
|
||||||
|
;; <https://bugs.python.org/issue34587>.
|
||||||
|
(delete-file "Lib/test/test_socket.py")
|
||||||
|
#t))))))))
|
||||||
|
|
||||||
;; Current major version.
|
;; Current major version.
|
||||||
(define-public python python-3)
|
(define-public python python-3)
|
||||||
|
|
||||||
|
@ -474,7 +493,7 @@ data types.")
|
||||||
("zlib" ,zlib)))))
|
("zlib" ,zlib)))))
|
||||||
|
|
||||||
(define-public python-minimal
|
(define-public python-minimal
|
||||||
(package (inherit python)
|
(package/inherit python
|
||||||
(name "python-minimal")
|
(name "python-minimal")
|
||||||
(outputs '("out"))
|
(outputs '("out"))
|
||||||
|
|
||||||
|
@ -486,8 +505,7 @@ data types.")
|
||||||
("zlib" ,zlib)))))
|
("zlib" ,zlib)))))
|
||||||
|
|
||||||
(define-public python-debug
|
(define-public python-debug
|
||||||
(package
|
(package/inherit python
|
||||||
(inherit python)
|
|
||||||
(name "python-debug")
|
(name "python-debug")
|
||||||
(outputs '("out" "debug"))
|
(outputs '("out" "debug"))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
|
@ -506,7 +524,7 @@ for more information.")))
|
||||||
(define* (wrap-python3 python
|
(define* (wrap-python3 python
|
||||||
#:optional
|
#:optional
|
||||||
(name (string-append (package-name python) "-wrapper")))
|
(name (string-append (package-name python) "-wrapper")))
|
||||||
(package (inherit python)
|
(package/inherit python
|
||||||
(name name)
|
(name name)
|
||||||
(source #f)
|
(source #f)
|
||||||
(build-system trivial-build-system)
|
(build-system trivial-build-system)
|
||||||
|
|
Loading…
Reference in New Issue