gnu: wicd: Add template for WPA2-TTLS.
* gnu/packages/patches/wicd-wpa2-ttls.patch: New file. * gnu/packages/wicd.scm (wicd)[source]: Add it. * gnu-system.am (dist_patch_DATA): Add it.
This commit is contained in:
parent
f5480572d0
commit
915363a3e2
|
@ -781,6 +781,7 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/wicd-bitrate-none-fix.patch \
|
gnu/packages/patches/wicd-bitrate-none-fix.patch \
|
||||||
gnu/packages/patches/wicd-get-selected-profile-fix.patch \
|
gnu/packages/patches/wicd-get-selected-profile-fix.patch \
|
||||||
gnu/packages/patches/wicd-urwid-1.3.patch \
|
gnu/packages/patches/wicd-urwid-1.3.patch \
|
||||||
|
gnu/packages/patches/wicd-wpa2-ttls.patch \
|
||||||
gnu/packages/patches/wmctrl-64-fix.patch \
|
gnu/packages/patches/wmctrl-64-fix.patch \
|
||||||
gnu/packages/patches/wpa-supplicant-CVE-2015-5310.patch \
|
gnu/packages/patches/wpa-supplicant-CVE-2015-5310.patch \
|
||||||
gnu/packages/patches/wpa-supplicant-CVE-2015-5314.patch \
|
gnu/packages/patches/wpa-supplicant-CVE-2015-5314.patch \
|
||||||
|
|
|
@ -0,0 +1,38 @@
|
||||||
|
Add a template for WPA2-TTLS, which is notably used by Eduroam.
|
||||||
|
|
||||||
|
--- a/encryption/templates/active
|
||||||
|
+++ b/encryption/templates/active
|
||||||
|
@@ -4,6 +4,7 @@ wpa-psk
|
||||||
|
wpa-psk-hex
|
||||||
|
wpa2-leap
|
||||||
|
wpa2-peap
|
||||||
|
+wpa2-ttls
|
||||||
|
wep-hex
|
||||||
|
wep-passphrase
|
||||||
|
wep-shared
|
||||||
|
diff --git a/encryption/templates/wpa2-ttls b/encryption/templates/wpa2-ttls
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..4f66a1e
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/encryption/templates/wpa2-ttls
|
||||||
|
@@ -0,0 +1,20 @@
|
||||||
|
+name = WPA2-TTLS (used notably by Eduroam)
|
||||||
|
+author = various contributors
|
||||||
|
+version = 1
|
||||||
|
+require identity *Identity anonymous_identity *Anonymous_identity password *Password ca_cert *Path_to_CA_Cert
|
||||||
|
+protected password *Password
|
||||||
|
+-----
|
||||||
|
+ctrl_interface=/var/run/wpa_supplicant
|
||||||
|
+network={
|
||||||
|
+ ssid="$_ESSID"
|
||||||
|
+ scan_ssid=$_SCAN
|
||||||
|
+ proto=WPA2
|
||||||
|
+ key_mgmt=WPA-EAP
|
||||||
|
+ group=CCMP TKIP
|
||||||
|
+ eap=TTLS
|
||||||
|
+ identity="$_IDENTITY"
|
||||||
|
+ password="$_PASSWORD"
|
||||||
|
+ anonymous_identity="$_ANONYMOUS_IDENTITY"
|
||||||
|
+ ca_cert="$_CA_CERT"
|
||||||
|
+ phase2="auth=PAP"
|
||||||
|
+}
|
|
@ -2,6 +2,7 @@
|
||||||
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
|
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
|
||||||
;;; Copyright © 2015 Pierre-Antoine Rault <par@rigelk.eu>
|
;;; Copyright © 2015 Pierre-Antoine Rault <par@rigelk.eu>
|
||||||
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
|
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
|
||||||
|
;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
|
@ -48,7 +49,8 @@
|
||||||
(patches (map search-patch
|
(patches (map search-patch
|
||||||
'("wicd-bitrate-none-fix.patch"
|
'("wicd-bitrate-none-fix.patch"
|
||||||
"wicd-get-selected-profile-fix.patch"
|
"wicd-get-selected-profile-fix.patch"
|
||||||
"wicd-urwid-1.3.patch")))))
|
"wicd-urwid-1.3.patch"
|
||||||
|
"wicd-wpa2-ttls.patch")))))
|
||||||
(build-system python-build-system)
|
(build-system python-build-system)
|
||||||
(native-inputs `(("gettext" ,gnu-gettext)))
|
(native-inputs `(("gettext" ,gnu-gettext)))
|
||||||
(inputs `(("dbus-glib" ,dbus-glib)
|
(inputs `(("dbus-glib" ,dbus-glib)
|
||||||
|
|
Loading…
Reference in New Issue