gnu: flex: Update to 2.6.0.
* gnu/packages/flex.scm (flex): Update to 2.6.0. [source]: Remove flex-bison-tests.patch. * gnu-system.am (dist_patch_DATA): Remove flex-bison-tests.patch. * gnu/packages/patches/flex-bison-tests.patch: Remove it.
This commit is contained in:
parent
bfcb7bcb73
commit
93b3a8b0ee
|
@ -463,7 +463,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/findutils-localstatedir.patch \
|
||||
gnu/packages/patches/findutils-test-xargs.patch \
|
||||
gnu/packages/patches/flashrom-use-libftdi1.patch \
|
||||
gnu/packages/patches/flex-bison-tests.patch \
|
||||
gnu/packages/patches/flint-ldconfig.patch \
|
||||
gnu/packages/patches/fltk-shared-lib-defines.patch \
|
||||
gnu/packages/patches/freeimage-CVE-2015-0852.patch \
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -31,15 +32,14 @@
|
|||
(define flex
|
||||
(package
|
||||
(name "flex")
|
||||
(version "2.5.37")
|
||||
(version "2.6.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://sourceforge/flex/flex-"
|
||||
version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"0ah5mi4j62b85a9rllv1004mzjb5cd0mn4glvz13p88rpx77pahp"))
|
||||
(patches (list (search-patch "flex-bison-tests.patch")))))
|
||||
"1sdqx63yadindzafrq1w31ajblf9gl1c301g068s20s7bbpi3ri4"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
(let ((bison-for-tests
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
The `test-bison-yyl{loc,val}' tests fail with "conflicting types for
|
||||
'testparse'" because `YYPARSE_PARAM' is undefined; work around that.
|
||||
|
||||
--- flex-2.5.37/tests/test-bison-yylloc/main.c 2012-11-22 18:17:01.000000000 +0100
|
||||
+++ flex-2.5.37/tests/test-bison-yylloc/main.c 2012-11-22 18:17:07.000000000 +0100
|
||||
@@ -21,6 +21,7 @@
|
||||
* PURPOSE.
|
||||
*/
|
||||
|
||||
+#define YYPARSE_PARAM scanner
|
||||
#include "parser.h"
|
||||
#include "scanner.h"
|
||||
|
||||
|
||||
--- flex-2.5.37/tests/test-bison-yylval/main.c 2012-11-22 18:17:42.000000000 +0100
|
||||
+++ flex-2.5.37/tests/test-bison-yylval/main.c 2012-11-22 18:17:49.000000000 +0100
|
||||
@@ -21,6 +21,7 @@
|
||||
* PURPOSE.
|
||||
*/
|
||||
|
||||
+#define YYPARSE_PARAM scanner
|
||||
#include "parser.h"
|
||||
#include "scanner.h"
|
||||
|
Loading…
Reference in New Issue