gnu: python-paste: Update to 3.0.4.

* gnu/packages/python-web.scm (python-paste): Update to 3.0.4.
[source]: Remove patch, add snippet to remove one test.
[native-inputs]: Add python-pytest, python-pytest-runner.
* gnu/packages/patches/python-paste-remove-website-test.patch: Remove
file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Efraim Flashner 2018-11-11 10:41:32 +02:00
parent 5ac2b2717f
commit 95176544d5
No known key found for this signature in database
GPG Key ID: 41AAE7DCCA3D8351
3 changed files with 12 additions and 28 deletions

View File

@ -1086,7 +1086,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-faker-fix-build-32bit.patch \
%D%/packages/patches/python-mox3-python3.6-compat.patch \
%D%/packages/patches/python-testtools.patch \
%D%/packages/patches/python-paste-remove-website-test.patch \
%D%/packages/patches/python-paste-remove-timing-test.patch \
%D%/packages/patches/python-pycrypto-CVE-2013-7459.patch \
%D%/packages/patches/python2-pygobject-2-gi-info-type-error-domain.patch \

View File

@ -1,21 +0,0 @@
Remove the test to see if the Python Paste website is up.
Obviously without network access there is no way for us to check this, and
it's pretty strange to test a project's website when you really mean to test
the project anyhow...
--- a/tests/test_proxy.py 2016-02-22 19:13:04.040117767 -0800
+++ b/tests/test_proxy.py 2016-02-22 19:13:04.040117767 -0800
@@ -1,12 +1,3 @@
from paste import proxy
from paste.fixture import TestApp
-def test_paste_website():
- # Not the most robust test...
- # need to test things like POSTing to pages, and getting from pages
- # that don't set content-length.
- app = proxy.Proxy('http://pythonpaste.org')
- app = TestApp(app)
- res = app.get('/')
- assert 'documentation' in res
-

View File

@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2016, 2017 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
@ -2628,19 +2628,25 @@ available in Django, but is a standalone package.")
(define-public python-paste
(package
(name "python-paste")
(version "2.0.3")
(version "3.0.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Paste" version))
(sha256
(base32
"062jk0nlxf6lb2wwj6zc20rlvrwsnikpkh90y0dn8cjch93s6ii3"))
(patches (search-patches "python-paste-remove-website-test.patch"
"python-paste-remove-timing-test.patch"))))
"01w26w9jyfkh0mfydhfz3dwy3pj3fw7mzvj0lna3vs8hyx1hwl0n"))
(patches (search-patches "python-paste-remove-timing-test.patch"))
(modules '((guix build utils)))
(snippet
'(begin
;; This test calls out to the internet.
(delete-file "tests/test_proxy.py") #t))))
(build-system python-build-system)
(native-inputs
`(("python-nose" ,python-nose)))
`(("python-pytest" ,python-pytest)
("python-pytest-runner" ,python-pytest-runner)
("python-nose" ,python-nose)))
(propagated-inputs
`(("python-six" ,python-six)))
(home-page "http://pythonpaste.org")