gnu: bitlbee: Update to 3.4.1.

* gnu/packages/patches/bitlbee-configure-doc-fix.patch: Delete file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/messaging.scm (bitlbee): Update to 3.4.1.
[source]: Remove patch.
master
Mark H Weaver 2016-02-27 21:05:45 -05:00
parent f376dc3acb
commit 9579118922
3 changed files with 3 additions and 20 deletions

View File

@ -426,7 +426,6 @@ dist_patch_DATA = \
gnu/packages/patches/bigloo-gc-shebangs.patch \
gnu/packages/patches/binutils-ld-new-dtags.patch \
gnu/packages/patches/binutils-loongson-workaround.patch \
gnu/packages/patches/bitlbee-configure-doc-fix.patch \
gnu/packages/patches/byobu-writable-status.patch \
gnu/packages/patches/calibre-drop-unrar.patch \
gnu/packages/patches/calibre-no-updates-dialog.patch \

View File

@ -101,14 +101,13 @@ keys, no previous conversation is compromised.")
(define-public bitlbee
(package
(name "bitlbee")
(version "3.4")
(version "3.4.1")
(source (origin
(method url-fetch)
(uri (string-append "http://get.bitlbee.org/src/bitlbee-"
(uri (string-append "https://get.bitlbee.org/src/bitlbee-"
version ".tar.gz"))
(sha256
(base32 "0plx4dryf8i6hz7vghg84z5f6w6rkw1l8ckl4c4wh5zxpd3ddfnf"))
(patches (list (search-patch "bitlbee-configure-doc-fix.patch")))))
(base32 "1qf0ypa9ba5jvsnpg9slmaran16hcc5fnfzbb1sdch1hjhchn2jh"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
("check" ,check)))

View File

@ -1,15 +0,0 @@
Fix the check for the prebuilt helpfile when xsltproc is not available.
--- bitlbee-3.4/configure.orig 2015-03-25 18:09:10.000000000 -0400
+++ bitlbee-3.4/configure 2015-05-20 14:51:33.627975970 -0400
@@ -650,8 +650,8 @@
if [ "$doc" = "1" ]; then
if [ ! -e doc/user-guide/help.txt ] && \
- ! type xmlto > /dev/null 2> /dev/null || \
- ! type xsltproc > /dev/null 2> /dev/null
+ (! type xmlto > /dev/null 2> /dev/null || \
+ ! type xsltproc > /dev/null 2> /dev/null)
then
echo
echo 'WARNING: Building from an unreleased source tree without prebuilt helpfile.'