gnu: lsh: Upgrade to 2.1.

* gnu/packages/lsh.scm (lsh): Upgrade to 2.1.  Add Nettle as an input.
  Remove now unneeded patches.
* gnu/packages/patches/lsh-guile-compat.patch,
  gnu/packages/patches/lsh-no-root-login.patch,
  gnu/packages/patches/lsh-pam-service-name.patch: Remove.
* gnu-system.am (dist_patch_DATA): Remove them.
This commit is contained in:
Ludovic Courtès 2013-06-27 22:27:26 +02:00
parent 6e1c4093d2
commit 96a8259a9d
5 changed files with 7 additions and 55 deletions

View File

@ -196,9 +196,6 @@ dist_patch_DATA = \
gnu/packages/patches/libapr-skip-getservbyname-test.patch \
gnu/packages/patches/libevent-dns-tests.patch \
gnu/packages/patches/libtool-skip-tests.patch \
gnu/packages/patches/lsh-guile-compat.patch \
gnu/packages/patches/lsh-no-root-login.patch \
gnu/packages/patches/lsh-pam-service-name.patch \
gnu/packages/patches/m4-gets-undeclared.patch \
gnu/packages/patches/m4-readlink-EINVAL.patch \
gnu/packages/patches/m4-s_isdir.patch \

View File

@ -24,6 +24,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages m4)
#:use-module (gnu packages linux)
#:use-module (gnu packages nettle)
#:use-module ((gnu packages compression)
#:renamer (symbol-prefix-proc 'guix:))
#:use-module (gnu packages multiprecision)
@ -52,7 +53,7 @@
(define-public lsh
(package
(name "lsh")
(version "2.0.4")
(version "2.1")
(source
(origin
(method url-fetch)
@ -60,10 +61,11 @@
version ".tar.gz"))
(sha256
(base32
"149hf49xcj99wwvi7hcb59igq4vpyv8har1br1if3lrsw5irsjv1"))))
"1qqjy9zfzgny0rkb27c8c7dfsylvb6n0ld8h3an2r83pmaqr9gwb"))))
(build-system gnu-build-system)
(inputs
`(("linux-pam" ,linux-pam)
`(("nettle" ,nettle)
("linux-pam" ,linux-pam)
("m4" ,m4)
("readline" ,readline)
("liboop" ,liboop)
@ -72,17 +74,9 @@
("guile" ,guile-final)
("gperf" ,gperf)
("psmisc" ,psmisc) ; for `killall'
("patch/no-root-login" ,(search-patch "lsh-no-root-login.patch"))
("patch/guile-compat" ,(search-patch "lsh-guile-compat.patch"))
("patch/pam-service-name"
,(search-patch "lsh-pam-service-name.patch"))))
))
(arguments
'(#:patches (list (assoc-ref %build-inputs "patch/no-root-login")
(assoc-ref %build-inputs "patch/pam-service-name")
(assoc-ref %build-inputs "patch/guile-compat"))
;; Skip the `configure' test that checks whether /dev/ptmx &
'(;; Skip the `configure' test that checks whether /dev/ptmx &
;; co. work as expected, because it relies on impurities (for
;; instance, /dev/pts may be unavailable in chroots.)
#:configure-flags '("lsh_cv_sys_unix98_ptys=yes")

View File

@ -1,9 +0,0 @@
Use (ice-9 rdelim) for `read-line'.
--- lsh-2.0.4/src/scm/guile-compat.scm 2012-12-03 23:28:01.000000000 +0100
+++ lsh-2.0.4/src/scm/guile-compat.scm 2012-12-03 23:28:04.000000000 +0100
@@ -21,3 +21,4 @@
;; Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
(use-syntax (ice-9 syncase))
+(use-modules (ice-9 rdelim))

View File

@ -1,16 +0,0 @@
Correctly handle the `--no-root-login' option.
--- lsh-2.0.4/src/lshd.c 2006-05-01 13:47:44.000000000 +0200
+++ lsh-2.0.4/src/lshd.c 2009-09-08 12:20:36.000000000 +0200
@@ -758,6 +758,10 @@ main_argp_parser(int key, char *arg, str
self->allow_root = 1;
break;
+ case OPT_NO_ROOT_LOGIN:
+ self->allow_root = 0;
+ break;
+
case OPT_KERBEROS_PASSWD:
self->pw_helper = PATH_KERBEROS_HELPER;
break;

View File

@ -1,14 +0,0 @@
Tell `lsh-pam-checkpw', the PAM password helper program, to use a more
descriptive service name.
--- lsh-2.0.4/src/lsh-pam-checkpw.c 2003-02-16 22:30:10.000000000 +0100
+++ lsh-2.0.4/src/lsh-pam-checkpw.c 2008-11-28 16:16:58.000000000 +0100
@@ -38,7 +38,7 @@
#include <security/pam_appl.h>
#define PWD_MAXLEN 1024
-#define SERVICE_NAME "other"
+#define SERVICE_NAME "lshd"
#define TIMEOUT 600
static int