gnu: mit-krb5: Update to 1.13.2.
* gnu/packages/mit-krb5.scm (mit-krb5): Update to 1.13.2. [native-inputs]: Remove "patch/init-fix". * gnu/packages/patches/mit-krb5-init-fix.patch: Delete file. * gnu-system.am (dist_patch_DATA): Remove it.
This commit is contained in:
parent
a124bbd2f4
commit
9715df7fbe
|
@ -586,7 +586,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/mcron-install.patch \
|
||||
gnu/packages/patches/mdadm-gcc-4.9-fix.patch \
|
||||
gnu/packages/patches/mhash-keygen-test-segfault.patch \
|
||||
gnu/packages/patches/mit-krb5-init-fix.patch \
|
||||
gnu/packages/patches/mpc123-initialize-ao.patch \
|
||||
gnu/packages/patches/mplayer2-theora-fix.patch \
|
||||
gnu/packages/patches/module-init-tools-moduledir.patch \
|
||||
|
|
|
@ -29,18 +29,17 @@
|
|||
(define-public mit-krb5
|
||||
(package
|
||||
(name "mit-krb5")
|
||||
(version "1.11.3")
|
||||
(version "1.13.2")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "http://web.mit.edu/kerberos/www/dist/krb5/"
|
||||
(string-copy version 0 (string-rindex version #\.))
|
||||
"/krb5-" version "-signed.tar"))
|
||||
(sha256 (base32
|
||||
"1daiaxgkxcryqs37w28v4x1vajqmay4l144d1zd9c2d7jjxr9gcs"))))
|
||||
"1qbdzyrws7d0q4filsibh28z54pd5l987jr0ygv43iq9085w6a75"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("patch/init-fix" ,(search-patch "mit-krb5-init-fix.patch"))
|
||||
("bison" ,bison)
|
||||
`(("bison" ,bison)
|
||||
("perl" ,perl)))
|
||||
(arguments
|
||||
'(#:phases
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
Fix the early context initialization code to avoid assuming that
|
||||
arguments will be evaluated from right to left.
|
||||
|
||||
Patch by Mark H Weaver <mhw@netris.org>.
|
||||
|
||||
--- src/lib/krb5/krb/t_cc_config.c.orig 2012-12-17 21:47:05.000000000 -0500
|
||||
+++ src/lib/krb5/krb/t_cc_config.c 2013-10-29 18:19:16.547994590 -0400
|
||||
@@ -117,8 +117,8 @@
|
||||
int c;
|
||||
unsigned int i;
|
||||
|
||||
- bail_on_err(context, "Error initializing Kerberos library",
|
||||
- krb5_init_context(&context));
|
||||
+ ret = krb5_init_context(&context);
|
||||
+ bail_on_err(context, "Error initializing Kerberos library", ret);
|
||||
bail_on_err(context, "Error getting location of default ccache",
|
||||
krb5_cc_default(context, &ccache));
|
||||
server = NULL;
|
Loading…
Reference in New Issue