gnu: ledger: Update to 3.1.3.
The patch applies but has been unnecessary since 3.1.2. * gnu/packages/finance.scm (ledger): Update to 3.1.3. [source]: Remove obsolete patch. * gnu/packages/patches/ledger-fix-uninitialized.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
54c9d7bb69
commit
9859800f5d
|
@ -957,7 +957,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/laby-make-install.patch \
|
||||
%D%/packages/patches/ldc-bootstrap-disable-tests.patch \
|
||||
%D%/packages/patches/ldc-disable-phobos-tests.patch \
|
||||
%D%/packages/patches/ledger-fix-uninitialized.patch \
|
||||
%D%/packages/patches/liba52-enable-pic.patch \
|
||||
%D%/packages/patches/liba52-link-with-libm.patch \
|
||||
%D%/packages/patches/liba52-set-soname.patch \
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
|
||||
;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
|
||||
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
|
||||
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
|
||||
;;; Copyright © 2018 Adriano Peluso <catonano@gmail.com>
|
||||
;;; Copyright © 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
|
||||
|
@ -139,7 +139,7 @@ line client and a client based on Qt.")
|
|||
(define-public ledger
|
||||
(package
|
||||
(name "ledger")
|
||||
(version "3.1.2")
|
||||
(version "3.1.3")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
|
@ -148,8 +148,7 @@ line client and a client based on Qt.")
|
|||
(commit (string-append "v" version))))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "0hwnipj2m9p95hhyv6kyq54m27g14r58gnsy2my883kxhpcyb2vc"))
|
||||
(patches (search-patches "ledger-fix-uninitialized.patch"))))
|
||||
(base32 "0bfnrqrd6wqgsngfpqi30xh6yy86pwl25iwzrqy44q31r0zl4mm3"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
`(#:configure-flags
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
This fixes failures of tests "BaseLine_opt-datetime-format" and
|
||||
"BaseLine_opt-time-report", which were printing an unexpected trailing '*' on
|
||||
the last line of output, e.g.:
|
||||
|
||||
@@ -5,4 +5,4 @@
|
||||
04/05/13 12:00 PM 04/05/13 01:30 PM 1.50h Lunch
|
||||
04/05/13 11:30 AM 04/05/13 12:00 PM 30.0m Walk
|
||||
--------------------------------------------------
|
||||
-
|
||||
+ *
|
||||
|
||||
Reported upstream at
|
||||
https://groups.google.com/d/msg/ledger-cli/EeJUrUk8YDc/pIR-LOTVEAAJ
|
||||
|
||||
diff --git a/src/account.h b/src/account.h
|
||||
index 1b97463d..f2555593 100644
|
||||
--- a/src/account.h
|
||||
+++ b/src/account.h
|
||||
@@ -187,7 +187,7 @@ public:
|
||||
|
||||
datetime_t earliest_checkin;
|
||||
datetime_t latest_checkout;
|
||||
- bool latest_checkout_cleared;
|
||||
+ bool latest_checkout_cleared = false;
|
||||
|
||||
std::set<path> filenames;
|
||||
std::set<string> accounts_referenced;
|
Loading…
Reference in New Issue