gnu: liblxqt: Update to 0.13.0.

* gnu/packages/lxqt.scm (liblxqt): Update to 0.13.0.
[source]: Remove patches.
[home-page]: Use HTTPS.
* gnu/packages/patches/liblxqt-include.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
master
Meiyo Peng 2018-10-18 10:30:35 +08:00 committed by 宋文武
parent 50401c2a68
commit 9861bcd182
No known key found for this signature in database
GPG Key ID: 26525665AE727D37
3 changed files with 26 additions and 28 deletions

View File

@ -885,7 +885,6 @@ dist_patch_DATA = \
%D%/packages/patches/libjxr-fix-function-signature.patch \
%D%/packages/patches/libjxr-fix-typos.patch \
%D%/packages/patches/libotr-test-auth-fix.patch \
%D%/packages/patches/liblxqt-include.patch \
%D%/packages/patches/libmad-armv7-thumb-pt1.patch \
%D%/packages/patches/libmad-armv7-thumb-pt2.patch \
%D%/packages/patches/libmad-frame-length.patch \

View File

@ -32,7 +32,9 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages qt))
#:use-module (gnu packages polkit)
#:use-module (gnu packages qt)
#:use-module (gnu packages xorg))
(define-public libqtxdg
(package
@ -72,29 +74,40 @@ in Qt.")
(define-public liblxqt
(package
(name "liblxqt")
(version "0.9.0")
(version "0.13.0")
(source
(origin
(method url-fetch)
(uri
(string-append "https://github.com/lxde/" name
"/archive/" version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(uri (string-append
"https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
(base32
"0mbl3qc0yfgfsndqrw8vg8k5irsy0pg2wrad8nwv0aphphd4n7rg"))
(patches (search-patches "liblxqt-include.patch"))))
(base32 "0fba0nq5b9fvvmklcikcd4nwhzlp5d6k1q1f80r34kncdzfvj7dl"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f))
(native-inputs `(("pkg-config" ,pkg-config)))
`(#:tests? #f ; no tests
#:configure-flags
;; TODO: prefetch translations files from 'lxqt-l10n'.
'("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
(lambda _
(substitute* "CMakeLists.txt"
(("DESTINATION \"\\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
"DESTINATION \"${CMAKE_INSTALL_PREFIX}/share/polkit-1/actions"))
#t)))))
(inputs
`(("kwindowsystem" ,kwindowsystem)
("libqtxdg" ,libqtxdg)
("qtbase" ,qtbase)
("libxscrnsaver" ,libxscrnsaver)
("polkit-qt" ,polkit-qt)
("qtsvg" ,qtsvg)
("qttools" ,qttools)
("qtx11extras" ,qtx11extras)))
(home-page "http://lxqt.org/")
(native-inputs
`(("lxqt-build-tools" ,lxqt-build-tools)))
(home-page "https://lxqt.org/")
(synopsis "Core utility library for all LXQt components")
(description "liblxqt provides the basic libraries shared by the
components of the LXQt desktop environment.")

View File

@ -1,14 +0,0 @@
Patch to fix build with Qt 5.5, taken from upstream:
https://github.com/lxde/liblxqt/commit/7303ea207de0771d6f450a31ec4a1ce69202869b
diff -u -r liblxqt-0.9.0.orig/lxqtnotification.h liblxqt-0.9.0/lxqtnotification.h
--- liblxqt-0.9.0.orig/lxqtnotification.h 2015-07-27 22:49:05.365166482 +0200
+++ liblxqt-0.9.0/lxqtnotification.h 2015-07-27 22:49:36.897606619 +0200
@@ -25,6 +25,7 @@
#ifndef LXQTNOTIFICATION_H
#define LXQTNOTIFICATION_H
+#include <QObject>
#include <QStringList>
#include "lxqtglobals.h"