gnu: libzip: Update to 1.3.0 (fixes CVE-2017-14107).
* gnu/packages/compression.scm (libzip): Update to 1.3.0. [source]: Remove patch. [arguments]: Remove custom 'patch-perl phase. * gnu/packages/patches/libzip-CVE-2017-12858.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
3b7c606965
commit
98df3a88b5
|
@ -812,7 +812,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/libxslt-generated-ids.patch \
|
%D%/packages/patches/libxslt-generated-ids.patch \
|
||||||
%D%/packages/patches/libxslt-CVE-2016-4738.patch \
|
%D%/packages/patches/libxslt-CVE-2016-4738.patch \
|
||||||
%D%/packages/patches/libxt-guix-search-paths.patch \
|
%D%/packages/patches/libxt-guix-search-paths.patch \
|
||||||
%D%/packages/patches/libzip-CVE-2017-12858.patch \
|
|
||||||
%D%/packages/patches/lierolibre-check-unaligned-access.patch \
|
%D%/packages/patches/lierolibre-check-unaligned-access.patch \
|
||||||
%D%/packages/patches/lierolibre-is-free-software.patch \
|
%D%/packages/patches/lierolibre-is-free-software.patch \
|
||||||
%D%/packages/patches/lierolibre-newer-libconfig.patch \
|
%D%/packages/patches/lierolibre-newer-libconfig.patch \
|
||||||
|
|
|
@ -1542,22 +1542,14 @@ manipulate, read, and write Zip archive files.")
|
||||||
(define-public libzip
|
(define-public libzip
|
||||||
(package
|
(package
|
||||||
(name "libzip")
|
(name "libzip")
|
||||||
(version "1.2.0")
|
(version "1.3.0")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append
|
(uri (string-append
|
||||||
"https://nih.at/libzip/libzip-" version ".tar.gz"))
|
"https://nih.at/libzip/libzip-" version ".tar.xz"))
|
||||||
(patches (search-patches "libzip-CVE-2017-12858.patch"))
|
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"17vxj2ffsxwh8lkc6801ppmwj15jp8q58rin76znxfbx88789ybc"))))
|
"0wykw0q9dwdzx0gssi2dpgckx9ggr2spzc1amjnff6wi6kz6x4xa"))))
|
||||||
(arguments
|
|
||||||
`(#:phases
|
|
||||||
(modify-phases %standard-phases
|
|
||||||
(add-before 'configure 'patch-perl
|
|
||||||
(lambda _
|
|
||||||
(substitute* "regress/runtest.in"
|
|
||||||
(("/usr/bin/env perl") (which "perl"))))))))
|
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("perl" ,perl)))
|
`(("perl" ,perl)))
|
||||||
(inputs
|
(inputs
|
||||||
|
|
|
@ -1,45 +0,0 @@
|
||||||
Fix CVE-2017-12858:
|
|
||||||
|
|
||||||
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-12858
|
|
||||||
|
|
||||||
Patch copied from upstream source repository:
|
|
||||||
|
|
||||||
https://github.com/nih-at/libzip/commit/2217022b7d1142738656d891e00b3d2d9179b796
|
|
||||||
|
|
||||||
From 2217022b7d1142738656d891e00b3d2d9179b796 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Thomas Klausner <tk@giga.or.at>
|
|
||||||
Date: Mon, 14 Aug 2017 10:55:44 +0200
|
|
||||||
Subject: [PATCH] Fix double free().
|
|
||||||
|
|
||||||
Found by Brian 'geeknik' Carpenter using AFL.
|
|
||||||
---
|
|
||||||
THANKS | 1 +
|
|
||||||
lib/zip_dirent.c | 3 ---
|
|
||||||
2 files changed, 1 insertion(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/THANKS b/THANKS
|
|
||||||
index be0cca9..a80ee1d 100644
|
|
||||||
--- a/THANKS
|
|
||||||
+++ b/THANKS
|
|
||||||
@@ -12,6 +12,7 @@ BALATON Zoltan <balaton@eik.bme.hu>
|
|
||||||
Benjamin Gilbert <bgilbert@backtick.net>
|
|
||||||
Boaz Stolk <bstolk@aweta.nl>
|
|
||||||
Bogdan <bogiebog@gmail.com>
|
|
||||||
+Brian 'geeknik' Carpenter <geeknik@protonmail.ch>
|
|
||||||
Chris Nehren <cnehren+libzip@pobox.com>
|
|
||||||
Coverity <info@coverity.com>
|
|
||||||
Dane Springmeyer <dane.springmeyer@gmail.com>
|
|
||||||
diff --git a/lib/zip_dirent.c b/lib/zip_dirent.c
|
|
||||||
index a369900..e5a7cc9 100644
|
|
||||||
--- a/lib/zip_dirent.c
|
|
||||||
+++ b/lib/zip_dirent.c
|
|
||||||
@@ -579,9 +579,6 @@ _zip_dirent_read(zip_dirent_t *zde, zip_source_t *src, zip_buffer_t *buffer, boo
|
|
||||||
}
|
|
||||||
|
|
||||||
if (!_zip_dirent_process_winzip_aes(zde, error)) {
|
|
||||||
- if (!from_buffer) {
|
|
||||||
- _zip_buffer_free(buffer);
|
|
||||||
- }
|
|
||||||
return -1;
|
|
||||||
}
|
|
||||||
|
|
Loading…
Reference in New Issue