gnu: tophat: Update to 2.1.1.
* gnu/packages/bioinformatics.scm (tophat): Update to 2.1.1. * gnu/packages/patches/tophat-build-with-later-seqan.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove patch.
This commit is contained in:
parent
f7618bf18e
commit
9a6808e0c0
|
@ -1177,7 +1177,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/tk-find-library.patch \
|
||||
%D%/packages/patches/ttf2eot-cstddef.patch \
|
||||
%D%/packages/patches/ttfautohint-source-date-epoch.patch \
|
||||
%D%/packages/patches/tophat-build-with-later-seqan.patch \
|
||||
%D%/packages/patches/totem-meson-easy-codec.patch \
|
||||
%D%/packages/patches/tuxpaint-stamps-path.patch \
|
||||
%D%/packages/patches/twinkle-include-qregexpvalidator.patch \
|
||||
|
|
|
@ -1332,7 +1332,7 @@ gapped, local, and paired-end alignment modes.")
|
|||
(define-public tophat
|
||||
(package
|
||||
(name "tophat")
|
||||
(version "2.1.0")
|
||||
(version "2.1.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
|
@ -1340,13 +1340,12 @@ gapped, local, and paired-end alignment modes.")
|
|||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"168zlzykq622zbgkh90a90f1bdgsxkscq2zxzbj8brq80hbjpyp7"))
|
||||
(patches (search-patches "tophat-build-with-later-seqan.patch"))
|
||||
"19add02kv2xhd6ihd779dr7x35ggym3jqr0m5c4315i1yfb0p11p"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
;; Remove bundled SeqAn and samtools
|
||||
(delete-file-recursively "src/SeqAn-1.3")
|
||||
(delete-file-recursively "src/SeqAn-1.4.2")
|
||||
(delete-file-recursively "src/samtools-0.1.18")
|
||||
#t))))
|
||||
(build-system gnu-build-system)
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
This patch resolves a build failure when building TopHat 2.1.0 with SeqAn 1.4.
|
||||
This is the relevant part of a patch originally posted here:
|
||||
https://lists.fu-berlin.de/pipermail/seqan-dev/2014-July/msg00001.html
|
||||
|
||||
--- a/src/segment_juncs.cpp
|
||||
+++ b/src/segment_juncs.cpp
|
||||
@@ -2050,10 +2050,13 @@ void juncs_from_ref_segs(RefSequenceTabl
|
||||
typedef map<uint32_t, IntronMotifs> MotifMap;
|
||||
|
||||
MotifMap ims;
|
||||
-
|
||||
- seqan::DnaStringReverseComplement rev_donor_dinuc(donor_dinuc);
|
||||
- seqan::DnaStringReverseComplement rev_acceptor_dinuc(acceptor_dinuc);
|
||||
-
|
||||
+
|
||||
+ typedef seqan::ModifiedString<
|
||||
+ seqan::ModifiedString<seqan::DnaString const, seqan::ModView<seqan::FunctorComplement<seqan::Dna> > >,
|
||||
+ seqan::ModReverse> ConstDnaStringReverseComplement;
|
||||
+ ConstDnaStringReverseComplement rev_donor_dinuc(donor_dinuc);
|
||||
+ ConstDnaStringReverseComplement rev_acceptor_dinuc(acceptor_dinuc);
|
||||
+
|
||||
if (talkative)
|
||||
fprintf(stderr, "Collecting potential splice sites in islands\n");
|
||||
|
Loading…
Reference in New Issue