gnu: sdl: Fix incompatibility with libx11-1.6.

* gnu/packages/patches/sdl-libx11-1.6.patch: New file
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/sdl.scm (sdl): Add patch.
master
Mark H Weaver 2014-12-26 00:32:48 -05:00
parent cc8b02f4a5
commit 9cb3036f0d
3 changed files with 17 additions and 1 deletions

View File

@ -442,6 +442,7 @@ dist_patch_DATA = \
gnu/packages/patches/ripperx-libm.patch \
gnu/packages/patches/scheme48-tests.patch \
gnu/packages/patches/scotch-test-threading.patch \
gnu/packages/patches/sdl-libx11-1.6.patch \
gnu/packages/patches/slim-session.patch \
gnu/packages/patches/slim-config.patch \
gnu/packages/patches/slim-sigusr1.patch \

View File

@ -0,0 +1,13 @@
Update _XData32 declaration in SDL_x11sym.h to match that of libx11 1.6.
--- SDL-1.2.15/src/video/x11/SDL_x11sym.h.~1~ 2012-01-19 01:30:06.000000000 -0500
+++ SDL-1.2.15/src/video/x11/SDL_x11sym.h 2014-12-26 00:22:36.445067694 -0500
@@ -165,7 +165,7 @@
*/
#ifdef LONG64
SDL_X11_MODULE(IO_32BIT)
-SDL_X11_SYM(int,_XData32,(Display *dpy,register long *data,unsigned len),(dpy,data,len),return)
+SDL_X11_SYM(int,_XData32,(Display *dpy,register _Xconst long *data,unsigned len),(dpy,data,len),return)
SDL_X11_SYM(void,_XRead32,(Display *dpy,register long *data,long len),(dpy,data,len),)
#endif

View File

@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@ -53,7 +54,8 @@
version ".tar.gz"))
(sha256
(base32
"005d993xcac8236fpvd1iawkz4wqjybkpn8dbwaliqz5jfkidlyn"))))
"005d993xcac8236fpvd1iawkz4wqjybkpn8dbwaliqz5jfkidlyn"))
(patches (list (search-patch "sdl-libx11-1.6.patch")))))
(build-system gnu-build-system)
(arguments
'(;; Explicitly link against Xext because SDL tries to dlopen it and