gnu: Add perl-text-markdown-discount.
* gnu/packages/markdown.scm (perl-text-markdown-discount): New variable. * gnu/packages/patches/perl-text-markdown-discount-use-system-markdown.patch: New file.
This commit is contained in:
parent
31d3a7c729
commit
9d46919f9c
|
@ -26,7 +26,9 @@
|
|||
#:use-module (guix build-system gnu)
|
||||
#:use-module (guix build-system trivial)
|
||||
#:use-module (guix build-system cmake)
|
||||
#:use-module (guix build-system perl)
|
||||
#:use-module (gnu packages compression)
|
||||
#:use-module (gnu packages)
|
||||
#:use-module (gnu packages perl)
|
||||
#:use-module (gnu packages python)
|
||||
#:use-module (gnu packages web))
|
||||
|
@ -144,6 +146,50 @@ convert it to structurally valid XHTML (or HTML).")
|
|||
(home-page "http://www.pell.portland.or.us/~orc/Code/discount/")
|
||||
(license bsd-3)))
|
||||
|
||||
(define-public perl-text-markdown-discount
|
||||
(package
|
||||
(name "perl-text-markdown-discount")
|
||||
(version "0.11")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"mirror://cpan/authors/id/S/SE/SEKIMURA/Text-Markdown-Discount-"
|
||||
version
|
||||
".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1xx7v3wnla7m6wa3h33whxw3vvincaicg4yra1b9wbzf2aix9rnw"))
|
||||
(patches
|
||||
(search-patches "perl-text-markdown-discount-use-system-markdown.patch"))))
|
||||
(build-system perl-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-before 'build 'set-ldflags
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
(substitute* "Makefile"
|
||||
(("OTHERLDFLAGS = ")
|
||||
(string-append
|
||||
"OTHERLDFLAGS = -lmarkdown -Wl,-rpath="
|
||||
(assoc-ref inputs "discount")
|
||||
"/lib"))))))))
|
||||
(inputs
|
||||
`(("discount" ,discount)))
|
||||
(home-page
|
||||
"http://search.cpan.org/dist/Text-Markdown-Discount")
|
||||
(synopsis
|
||||
"Fast function for converting Markdown to HTML using Discount")
|
||||
(description
|
||||
"Text::Markdown::Discount is a Perl extension to the Discount markdown
|
||||
implementation.
|
||||
|
||||
@example
|
||||
use Text::Markdown::Discount;
|
||||
my $html = markdown($text)
|
||||
@end example")
|
||||
(license perl-license)))
|
||||
|
||||
(define-public cmark
|
||||
(package
|
||||
(name "cmark")
|
||||
|
|
|
@ -0,0 +1,32 @@
|
|||
Description: Use the markdown library provided by the libmarkdown2 package.
|
||||
Author: Alessandro Ghedini <al3xbio@gmail.com>
|
||||
Origin: vendor
|
||||
Forwarded: not-needed
|
||||
Last-Update: 2012-01-01
|
||||
|
||||
--- a/Makefile.PL
|
||||
+++ b/Makefile.PL
|
||||
@@ -57,12 +57,6 @@
|
||||
|
||||
|
||||
|
||||
-sub MY::postamble {
|
||||
- return sprintf('
|
||||
-$(MYEXTLIB):
|
||||
- %s
|
||||
-', qq{( cd $extdir; CC='cc -fPIC' sh configure.sh; make )\n});
|
||||
-}
|
||||
|
||||
WriteMakefile(
|
||||
NAME => 'Text::Markdown::Discount',
|
||||
@@ -71,8 +65,6 @@
|
||||
($] >= 5.005 ?
|
||||
(ABSTRACT_FROM => 'lib/Text/Markdown/Discount.pm',
|
||||
AUTHOR => 'Masayoshi Sekimura <sekimura@cpan.org>') : ()),
|
||||
- LIBS => '-L' . $extdir,
|
||||
- INC => '-I. -I' . $extdir,
|
||||
- MYEXTLIB => $myextlib,
|
||||
- clean => { FILES => $clean_files },
|
||||
+ LIBS => '-lmarkdown',
|
||||
+ INC => '-I.',
|
||||
);
|
Loading…
Reference in New Issue