gnu: python-dendropy: Update to 4.4.0.

* gnu/packages/bioinformatics.scm (python-dendropy, python2-dendropy):
Update to 4.4.0.
[source]: Use GitHub URI. Remove patch.
[properties]: Remove field.
(python2-dendropy)[arguments]: Run tests with setup.py.
[native-inputs]: Remove 'python2-nose.
* gnu/packages/patches/python-dendropy-fix-tests.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Delete it.
master
Ben Woodcroft 2018-07-29 22:44:37 +10:00
parent 19601e895b
commit 9e0c135c39
No known key found for this signature in database
GPG Key ID: 2A6AD9F4AAC20DF6
3 changed files with 9 additions and 61 deletions

View File

@ -1064,7 +1064,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-3-fix-tests.patch \
%D%/packages/patches/python-axolotl-AES-fix.patch \
%D%/packages/patches/python-cairocffi-dlopen-path.patch \
%D%/packages/patches/python-dendropy-fix-tests.patch \
%D%/packages/patches/python-fix-tests.patch \
%D%/packages/patches/python-genshi-add-support-for-python-3.4-AST.patch \
%D%/packages/patches/python-genshi-buildable-on-python-2.7.patch \

View File

@ -1971,15 +1971,18 @@ accessing bigWig files.")
(define-public python-dendropy
(package
(name "python-dendropy")
(version "4.2.0")
(version "4.4.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "DendroPy" version))
;; Source from GitHub so that tests are included.
(uri
(string-append "https://github.com/jeetsukumaran/DendroPy/archive/v"
version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
"15c7s3d5gf19ljsxvq5advaa752wfi7pwrdjyhzmg85hccyvp47p"))
(patches (search-patches "python-dendropy-fix-tests.patch"))))
"0v2fccny5xjaah546bsch1mw4kh61qq5frz2ibllxs9mp6ih9bsn"))))
(build-system python-build-system)
(home-page "http://packages.python.org/DendroPy/")
(synopsis "Library for phylogenetics and phylogenetic computing")
@ -1987,23 +1990,10 @@ accessing bigWig files.")
"DendroPy is a library for phylogenetics and phylogenetic computing: reading,
writing, simulation, processing and manipulation of phylogenetic
trees (phylogenies) and characters.")
(license license:bsd-3)
(properties `((python2-variant . ,(delay python2-dendropy))))))
(license license:bsd-3)))
(define-public python2-dendropy
(let ((base (package-with-python2 (strip-python2-variant python-dendropy))))
(package
(inherit base)
(arguments
`(#:python ,python-2
#:phases
(modify-phases %standard-phases
(replace 'check
;; There is currently a test failure that only happens on some
;; systems, and only using "setup.py test"
(lambda _ (zero? (system* "nosetests")))))))
(native-inputs `(("python2-nose" ,python2-nose)
,@(package-native-inputs base))))))
(package-with-python2 python-dendropy))
(define-public python-py2bit
(package

View File

@ -1,41 +0,0 @@
This patch fixes two test failures. It was downloaded from:
https://github.com/jeetsukumaran/DendroPy/commit/93f984bba7a6c588a28ca87f4e557ce283809453
From 93f984bba7a6c588a28ca87f4e557ce283809453 Mon Sep 17 00:00:00 2001
From: jeetsukumaran <jeetsukumaran@gmail.com>
Date: Tue, 21 Feb 2017 16:41:01 -0500
Subject: [PATCH] Update to Python 3 container and iteration semantics
---
dendropy/dataio/newickreader.py | 3 ++-
dendropy/datamodel/treemodel.py | 3 +++
2 files changed, 5 insertions(+), 1 deletion(-)
diff --git a/dendropy/dataio/newickreader.py b/dendropy/dataio/newickreader.py
index 6dcf3c5..f978729 100644
--- a/dendropy/dataio/newickreader.py
+++ b/dendropy/dataio/newickreader.py
@@ -303,7 +303,8 @@ def tree_iter(self,
taxon_symbol_map_fn=taxon_symbol_mapper.require_taxon_for_symbol)
yield tree
if tree is None:
- raise StopIteration
+ # raise StopIteration
+ return
def _read(self,
stream,
diff --git a/dendropy/datamodel/treemodel.py b/dendropy/datamodel/treemodel.py
index 0ecfe31..73146f0 100644
--- a/dendropy/datamodel/treemodel.py
+++ b/dendropy/datamodel/treemodel.py
@@ -772,6 +772,9 @@ def __hash__(self):
def __eq__(self, other):
return self is other
+ def __lt__(self, other):
+ return id(self) < id(other)
+
###########################################################################
### Basic Structure