gnu: byobu: Update to 5.127.

* gnu/packages/screen.scm (byobu): Update to 5.127.
* gnu/packages/patches/byobu-writable-status.patch: Adjust context
accordingly.
master
Tobias Geerinckx-Rice 2018-08-23 03:11:30 +02:00
parent f868276b8a
commit 9e29921162
No known key found for this signature in database
GPG Key ID: 0DB0FF884F556D79
2 changed files with 10 additions and 10 deletions

View File

@ -1,13 +1,13 @@
Skeleton status files are installed read-only. When copying to the config dir
upon initialization, make sure they end up writable.
--- byobu-5.98/usr/bin/byobu-janitor.in
+++ byobu-5.98/usr/bin/byobu-janitor.in
--- byobu-5.127/usr/bin/byobu-janitor.in
+++ byobu-5.127/usr/bin/byobu-janitor.in
@@ -82,6 +82,7 @@
if [ ! -r "$BYOBU_CONFIG_DIR/$f" ]; then
# Copy from skeleton, if possible
cp -f "$BYOBU_PREFIX/share/$PKG/status/$f" "$BYOBU_CONFIG_DIR/$f"
+ chmod +w "$BYOBU_CONFIG_DIR/$f"
# Enable ec2_cost, if we're in ec2 and seeding a new setup
if metadata_available; then
$BYOBU_SED_INLINE -e "s/#ec2_cost/ec2_cost/g" "$($BYOBU_READLINK -f $BYOBU_CONFIG_DIR/$f)"
fi
done

View File

@ -5,7 +5,7 @@
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@ -102,7 +102,7 @@ controlling terminal and attach to it later.")
(define-public byobu
(package
(name "byobu")
(version "5.98")
(version "5.127")
(source
(origin
(method url-fetch)
@ -111,11 +111,11 @@ controlling terminal and attach to it later.")
version ".orig.tar.gz"))
(sha256
(base32
"1s8nh4wbds1nh52i0d1hy1b308jjf4siwpq92lna1zh9ll4x71j5"))
"0fznlj454vgxgzfw3avmvvjpawggs66da5l8k6v0lnzzd75wgbsb"))
(patches (search-patches "byobu-writable-status.patch"))))
(build-system gnu-build-system)
(inputs
`(("python" ,python-wrapper) ;for config and session GUIs
`(("python" ,python-wrapper) ; for config and session GUIs
("python-newt" ,newt "python")))
(arguments
`(#:phases
@ -123,7 +123,7 @@ controlling terminal and attach to it later.")
(add-before
'configure 'provide-locale
(lambda* (#:key inputs #:allow-other-keys)
(let ((libc (assoc-ref inputs "libc"))) ;implicit input
(let ((libc (assoc-ref inputs "libc"))) ; implicit input
(substitute* "usr/bin/byobu.in"
(("locale") (string-append libc "/bin/locale")))
#t)))