gnu: grep: Update to 2.22.
* gnu/packages/base.scm (grep): Upgrade to 2.22. Remove 'grep-CVE-2015-1345.patch'. * gnu/packages/patches/grep-CVE-2015-1345.patch: Remove. * gnu-system.am (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
e17d513381
commit
9eb681a02d
|
@ -482,7 +482,6 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch \
|
gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch \
|
||||||
gnu/packages/patches/gobject-introspection-cc.patch \
|
gnu/packages/patches/gobject-introspection-cc.patch \
|
||||||
gnu/packages/patches/gobject-introspection-girepository.patch \
|
gnu/packages/patches/gobject-introspection-girepository.patch \
|
||||||
gnu/packages/patches/grep-CVE-2015-1345.patch \
|
|
||||||
gnu/packages/patches/grub-gets-undeclared.patch \
|
gnu/packages/patches/grub-gets-undeclared.patch \
|
||||||
gnu/packages/patches/grub-freetype.patch \
|
gnu/packages/patches/grub-freetype.patch \
|
||||||
gnu/packages/patches/gsl-poly-test-fix-pt1.patch \
|
gnu/packages/patches/gsl-poly-test-fix-pt1.patch \
|
||||||
|
|
|
@ -73,15 +73,14 @@ command-line arguments, multiple languages, and so on.")
|
||||||
(define-public grep
|
(define-public grep
|
||||||
(package
|
(package
|
||||||
(name "grep")
|
(name "grep")
|
||||||
(version "2.21")
|
(version "2.22")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/grep/grep-"
|
(uri (string-append "mirror://gnu/grep/grep-"
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1pp5n15qwxrw1pibwjhhgsibyv5cafhamf8lwzjygs6y00fa2i2j"))
|
"1srn321x7whlhs5ks36zlcrrmj4iahll8fxwsh1vbz3v04px54fa"))))
|
||||||
(patches (list (search-patch "grep-CVE-2015-1345.patch")))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(synopsis "Print lines matching a pattern")
|
(synopsis "Print lines matching a pattern")
|
||||||
(description
|
(description
|
||||||
|
|
|
@ -1,17 +0,0 @@
|
||||||
Fix CVE-2015-1345. From upstream commit
|
|
||||||
83a95bd8c8561875b948cadd417c653dbe7ef2e2
|
|
||||||
by Yuliy Pisetsky <ypisetsky@fb.com>.
|
|
||||||
|
|
||||||
diff --git a/src/kwset.c b/src/kwset.c
|
|
||||||
index 4003c8d..376f7c3 100644
|
|
||||||
--- a/src/kwset.c
|
|
||||||
+++ b/src/kwset.c
|
|
||||||
@@ -643,6 +643,8 @@ bmexec_trans (kwset_t kwset, char const *text, size_t size)
|
|
||||||
if (! tp)
|
|
||||||
return -1;
|
|
||||||
tp++;
|
|
||||||
+ if (ep <= tp)
|
|
||||||
+ break;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
}
|
|
Loading…
Reference in New Issue