gnu: gnome-todo: Update to 3.28.1.
* gnu/packages/gnome.scm (gnome-todo): Update to 3.28.1. * gnu/local.mk (dist_patch_DATA): Remove patch. * gnu/packages/patches/gnome-todo-libical-compat.patch: Remove file.
This commit is contained in:
parent
a286b5ebda
commit
9f3c6c8825
|
@ -838,7 +838,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gmp-arm-asm-nothumb.patch \
|
||||
%D%/packages/patches/gmp-faulty-test.patch \
|
||||
%D%/packages/patches/gnome-shell-theme.patch \
|
||||
%D%/packages/patches/gnome-todo-libical-compat.patch \
|
||||
%D%/packages/patches/gnome-tweak-tool-search-paths.patch \
|
||||
%D%/packages/patches/gnucash-fix-test-transaction-failure.patch \
|
||||
%D%/packages/patches/gnutls-skip-trust-store-test.patch \
|
||||
|
|
|
@ -6440,16 +6440,15 @@ desktop. It supports multiple calendars, month, week and year view.")
|
|||
(define-public gnome-todo
|
||||
(package
|
||||
(name "gnome-todo")
|
||||
(version "3.26.2")
|
||||
(version "3.28.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnome/sources/" name "/"
|
||||
(version-major+minor version) "/"
|
||||
name "-" version ".tar.xz"))
|
||||
(patches (search-patches "gnome-todo-libical-compat.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"106xx1w18pxjmj5k0k2qjzi6b3c3kaz7b5kyrpknykibnr401ff9"))))
|
||||
"08ygqbib72jlf9y0a16k54zz51sncpq2wa18wp81v46q8301ymy7"))))
|
||||
(build-system meson-build-system)
|
||||
(arguments
|
||||
'(#:glib-or-gtk? #t
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
Fix compatibility with libical 3.0.
|
||||
|
||||
Patch copied from Arch Linux:
|
||||
https://git.archlinux.org/svntogit/packages.git/tree/trunk/gnome-todo-3.26.2-libical-3.0.patch?h=packages/gnome-todo
|
||||
|
||||
diff -up gnome-todo-3.26.2/src/gtd-task.c.libical-3.0 gnome-todo-3.26.2/src/gtd-task.c
|
||||
--- gnome-todo-3.26.2/src/gtd-task.c.libical-3.0 2017-11-08 14:53:53.484294926 +0100
|
||||
+++ gnome-todo-3.26.2/src/gtd-task.c 2017-11-08 14:53:57.208294874 +0100
|
||||
@@ -778,7 +778,7 @@ gtd_task_set_complete (GtdTask *task,
|
||||
dt->minute = g_date_time_get_minute (now);
|
||||
dt->second = g_date_time_get_seconds (now);
|
||||
dt->is_date = 0;
|
||||
- dt->is_utc = 1;
|
||||
+ dt->zone = icaltimezone_get_utc_timezone ();
|
||||
|
||||
/* convert timezone
|
||||
*
|
Loading…
Reference in New Issue