gnu: scribus: Update to 1.5.1.

* gnu/packages/scribus.scm (scribus): Update to 1.5.1.
[source]: Remove patch.
* gnu/packages/patches/scribus-qobject.patch: Delete file.
* gnu-system.am (dist_patch_DATA): Remove it.
master
Ricardo Wurmus 2016-02-27 16:31:04 +01:00
parent b951e26fe5
commit a003b5b650
3 changed files with 2 additions and 21 deletions

View File

@ -702,7 +702,6 @@ dist_patch_DATA = \
gnu/packages/patches/sed-hurd-path-max.patch \
gnu/packages/patches/scheme48-tests.patch \
gnu/packages/patches/scotch-test-threading.patch \
gnu/packages/patches/scribus-qobject.patch \
gnu/packages/patches/sdl-libx11-1.6.patch \
gnu/packages/patches/serf-comment-style-fix.patch \
gnu/packages/patches/serf-deflate-buckets-test-fix.patch \

View File

@ -1,17 +0,0 @@
See upstream bug report: http://bugs.scribus.net/view.php?id=13102
scribus/sclayer.cpp | 1 +
1 file changed, 1 insertion(+)
diff --git a/scribus/sclayer.cpp b/scribus/sclayer.cpp
index 502112b..4da7bd5 100644
--- a/scribus/sclayer.cpp
+++ b/scribus/sclayer.cpp
@@ -9,6 +9,7 @@ for which a new license (GPL+exception) is in place.
#include <QHash> //necessary to avoid msvc warnings induced by SCRIBUS_API on ScLayers + early instanciation of templates
#include <QVector> //necessary to avoid msvc warnings induced by SCRIBUS_API on ScLayers + early instanciation of templates
+#include <QObject>
#include <QtAlgorithms>
ScLayer::ScLayer(void)

View File

@ -39,15 +39,14 @@
(define-public scribus
(package
(name "scribus")
(version "1.5.0")
(version "1.5.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/scribus/scribus-devel/"
version "/scribus-" version ".tar.xz"))
(sha256
(base32
"0s4f9q2nyqrrv4wc1ddf2admkmf9m33wmwp73ba5b4vi29nydnx3"))
(patches (list (search-patch "scribus-qobject.patch")))))
"0f2adwg58w37sdi3xrk8xqw486p3pcfjaypcsswjl76r2f3yd0hq"))))
(build-system cmake-build-system)
(arguments `(#:tests? #f)) ; no test target
(inputs