gnu: crawl, crawl-tiles: Update to 0.22.1.

* gnu/packages/games.scm (crawl, crawl-tiles): Update to 0.22.1.
* gnu/packages/patches/crawl-upgrade-saves.patch: Update accordingly.
master
Kei Kebreau 2018-10-07 20:14:02 -04:00
parent a18accba46
commit a041066374
No known key found for this signature in database
GPG Key ID: E6A5EE3C19467A0D
2 changed files with 15 additions and 14 deletions

View File

@ -4397,7 +4397,7 @@ fish. The whole game is accompanied by quiet, comforting music.")
(define-public crawl
(package
(name "crawl")
(version "0.21.0")
(version "0.22.1")
(source
(origin
(method url-fetch)
@ -4411,7 +4411,7 @@ fish. The whole game is accompanied by quiet, comforting music.")
version "-nodeps.tar.xz")))
(sha256
(base32
"0mmnkch8s9l7dh136yjvcyjr0vmyzv7z370rlcyir91qz6gg82n1"))
"1qc90wwbxvjzqq66n8kfr0a2ny7sfvv2n84si67jiv2887d0ws6k"))
(patches (search-patches "crawl-upgrade-saves.patch"))))
(build-system gnu-build-system)
(inputs

View File

@ -5,8 +5,9 @@ By default crawl checks for a mtime difference on files in DATADIR to see if an
upgrade is required, but guix nulls all file dates,
and crawl would never upgrade saves.
--- a/source/database.cc 2016-05-31 09:56:08.000000000 +0200
+++ a/source/database.cc 2017-06-05 03:00:19.270632107 +0200
diff -ur a/source/database.cc b/source/database.cc
--- a/source/database.cc 2018-08-09 21:49:26.000000000 -0400
+++ b/source/database.cc 2018-10-07 18:06:41.022445789 -0400
@@ -25,6 +25,7 @@
#include "syscalls.h"
#include "threads.h"
@ -23,16 +24,16 @@ and crawl would never upgrade saves.
TextDB *_parent;
const char* lang() { return _parent ? Options.lang_name : 0; }
public:
@@ -165,7 +167,7 @@
@@ -163,7 +165,7 @@
TextDB::TextDB(const char* db_name, const char* dir, ...)
: _db_name(db_name), _directory(dir),
TextDB::TextDB(const char* db_name, const char* dir, vector<string> files)
: _db_name(db_name), _directory(dir), _input_files(files),
- _db(nullptr), timestamp(""), _parent(0), translation(0)
+ _db(nullptr), timestamp(""), version(""), _parent(0), translation(0)
{
va_list args;
va_start(args, dir);
@@ -187,7 +189,7 @@
}
@@ -171,7 +173,7 @@
: _db_name(parent->_db_name),
_directory(parent->_directory + Options.lang_name + "/"),
_input_files(parent->_input_files), // FIXME: pointless copy
@ -41,7 +42,7 @@ and crawl would never upgrade saves.
{
}
@@ -202,6 +204,9 @@
@@ -186,6 +188,9 @@
return false;
timestamp = _query_database(*this, "TIMESTAMP", false, false, true);
@ -51,7 +52,7 @@ and crawl would never upgrade saves.
if (timestamp.empty())
return false;
@@ -245,6 +250,9 @@
@@ -229,6 +234,9 @@
string ts;
bool no_files = true;
@ -61,7 +62,7 @@ and crawl would never upgrade saves.
for (const string &file : _input_files)
{
string full_input_path = _directory + file;
@@ -261,7 +269,7 @@
@@ -245,7 +253,7 @@
ts += buf;
}
@ -70,7 +71,7 @@ and crawl would never upgrade saves.
{
// No point in empty databases, although for simplicity keep ones
// for disappeared translations for now.
@@ -321,7 +329,10 @@
@@ -313,7 +321,10 @@
_store_text_db(full_input_path, _db);
}
}