gnu: ghostscript: Fix CVE-2018-10194.
* gnu/packages/ghostscript.scm (ghostscript)[replacement]: New field. (ghostscript/fixed): New variable. * gnu/packages/patches/ghostscript-CVE-2018-10194.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
276598b69b
commit
a1e3da63cb
|
@ -714,6 +714,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/geoclue-config.patch \
|
%D%/packages/patches/geoclue-config.patch \
|
||||||
%D%/packages/patches/ghc-8.0-fall-back-to-madv_dontneed.patch \
|
%D%/packages/patches/ghc-8.0-fall-back-to-madv_dontneed.patch \
|
||||||
%D%/packages/patches/ghc-dont-pass-linker-flags-via-response-files.patch \
|
%D%/packages/patches/ghc-dont-pass-linker-flags-via-response-files.patch \
|
||||||
|
%D%/packages/patches/ghostscript-CVE-2018-10194.patch \
|
||||||
%D%/packages/patches/ghostscript-no-header-id.patch \
|
%D%/packages/patches/ghostscript-no-header-id.patch \
|
||||||
%D%/packages/patches/ghostscript-no-header-uuid.patch \
|
%D%/packages/patches/ghostscript-no-header-uuid.patch \
|
||||||
%D%/packages/patches/ghostscript-no-header-creationdate.patch \
|
%D%/packages/patches/ghostscript-no-header-creationdate.patch \
|
||||||
|
|
|
@ -132,6 +132,7 @@ printing, and psresize, for adjusting page sizes.")
|
||||||
(define-public ghostscript
|
(define-public ghostscript
|
||||||
(package
|
(package
|
||||||
(name "ghostscript")
|
(name "ghostscript")
|
||||||
|
(replacement ghostscript/fixed)
|
||||||
(version "9.23")
|
(version "9.23")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
|
@ -250,6 +251,16 @@ output file formats and printers.")
|
||||||
(home-page "https://www.ghostscript.com/")
|
(home-page "https://www.ghostscript.com/")
|
||||||
(license license:agpl3+)))
|
(license license:agpl3+)))
|
||||||
|
|
||||||
|
(define-public ghostscript/fixed
|
||||||
|
(hidden-package
|
||||||
|
(package
|
||||||
|
(inherit ghostscript)
|
||||||
|
(source
|
||||||
|
(origin
|
||||||
|
(inherit (package-source ghostscript))
|
||||||
|
(patches (append (origin-patches (package-source ghostscript))
|
||||||
|
(search-patches "ghostscript-CVE-2018-10194.patch"))))))))
|
||||||
|
|
||||||
(define-public ghostscript/x
|
(define-public ghostscript/x
|
||||||
(package/inherit ghostscript
|
(package/inherit ghostscript
|
||||||
(name (string-append (package-name ghostscript) "-with-x"))
|
(name (string-append (package-name ghostscript) "-with-x"))
|
||||||
|
|
|
@ -0,0 +1,52 @@
|
||||||
|
Fix CVE-2018-10194:
|
||||||
|
|
||||||
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10194
|
||||||
|
https://bugs.ghostscript.com/show_bug.cgi?id=699255
|
||||||
|
|
||||||
|
Patch copied from upstream source repository:
|
||||||
|
|
||||||
|
https://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=39b1e54b2968620723bf32e96764c88797714879
|
||||||
|
|
||||||
|
From 39b1e54b2968620723bf32e96764c88797714879 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Ken Sharp <ken.sharp@artifex.com>
|
||||||
|
Date: Wed, 18 Apr 2018 15:46:32 +0100
|
||||||
|
Subject: [PATCH] pdfwrite - Guard against trying to output an infinite number
|
||||||
|
|
||||||
|
Bug #699255 " Buffer overflow on pprintg1 due to mishandle postscript file data to pdf"
|
||||||
|
|
||||||
|
The file uses an enormous parameter to xyxhow, causing an overflow in
|
||||||
|
the calculation of text positioning (value > 1e39).
|
||||||
|
|
||||||
|
Since this is basically a nonsense value, and PostScript only supports
|
||||||
|
real values up to 1e38, this patch follows the same approach as for
|
||||||
|
a degenerate CTM, and treats it as 0.
|
||||||
|
|
||||||
|
Adobe Acrobat Distiller throws a limitcheck error, so we could do that
|
||||||
|
instead if this approach proves to be a problem.
|
||||||
|
---
|
||||||
|
devices/vector/gdevpdts.c | 7 ++++++-
|
||||||
|
1 file changed, 6 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/devices/vector/gdevpdts.c b/devices/vector/gdevpdts.c
|
||||||
|
index 848ad781f..172fe6bc3 100644
|
||||||
|
--- a/devices/vector/gdevpdts.c
|
||||||
|
+++ b/devices/vector/gdevpdts.c
|
||||||
|
@@ -103,9 +103,14 @@ append_text_move(pdf_text_state_t *pts, double dw)
|
||||||
|
static int
|
||||||
|
set_text_distance(gs_point *pdist, double dx, double dy, const gs_matrix *pmat)
|
||||||
|
{
|
||||||
|
- int code = gs_distance_transform_inverse(dx, dy, pmat, pdist);
|
||||||
|
+ int code;
|
||||||
|
double rounded;
|
||||||
|
|
||||||
|
+ if (dx > 1e38 || dy > 1e38)
|
||||||
|
+ code = gs_error_undefinedresult;
|
||||||
|
+ else
|
||||||
|
+ code = gs_distance_transform_inverse(dx, dy, pmat, pdist);
|
||||||
|
+
|
||||||
|
if (code == gs_error_undefinedresult) {
|
||||||
|
/* The CTM is degenerate.
|
||||||
|
Can't know the distance in user space.
|
||||||
|
--
|
||||||
|
2.18.0
|
||||||
|
|
Loading…
Reference in New Issue