gnu: meson: Update to 0.47.1.

* gnu/packages/build-tools.scm (meson): Update to 0.47.1.
* gnu/packages/patches/meson-for-build-rpath.patch: Adjust.
master
Ricardo Wurmus 2018-08-10 16:00:22 +02:00
parent bedf0535ff
commit a3baaaa07a
No known key found for this signature in database
GPG Key ID: 197A5888235FACAC
2 changed files with 22 additions and 20 deletions

View File

@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Corentin Bocquillon <corentin@nybble.fr>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
@ -100,7 +100,7 @@ generate such a compilation database.")
(define-public meson
(package
(name "meson")
(version "0.46.1")
(version "0.47.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/mesonbuild/meson/"
@ -108,7 +108,7 @@ generate such a compilation database.")
version ".tar.gz"))
(sha256
(base32
"0y7f5hhy16q99l7x06x8sid9p9dbg6d7i60zs7c07cz5ww1plj8r"))))
"19mdap2ncvczajx220bd73xmwhd8x906382y18cn9c5syxwxwwyn"))))
(build-system python-build-system)
(arguments
`(;; FIXME: Tests require many additional inputs, a fix for the RUNPATH

View File

@ -2,22 +2,24 @@ This patch removes a part of meson that clears the rpath upon installation.
This will only be applied to a special version of meson, used for the
meson-build-system.
Patch by Peter Mikkelsen <petermikkelsen10@gmail.com>
--- meson-0.42.0/mesonbuild/scripts/meson_install.py.orig 2017-09-09 01:49:39.147374148 +0200
+++ meson-0.42.0/mesonbuild/scripts/meson_install.py 2017-09-09 01:51:01.209134717 +0200
@@ -391,14 +391,6 @@
print("Symlink creation does not work on this platform. "
"Skipping all symlinking.")
printed_symlink_error = True
- if os.path.isfile(outname):
- try:
- depfixer.fix_rpath(outname, install_rpath, False)
- except SystemExit as e:
- if isinstance(e.code, int) and e.code == 0:
- pass
- else:
- raise
Patch for Meson 0.42.0 by Peter Mikkelsen <petermikkelsen10@gmail.com>
Adjusted for Meson 0.47.1 by Ricardo Wurmus <rekado@elephly.net>
--- meson-0.47.1/mesonbuild/minstall.py.old 2018-08-10 11:01:27.812327013 +0200
+++ meson-0.47.1/mesonbuild/minstall.py 2018-08-10 11:01:51.940368505 +0200
@@ -436,15 +436,6 @@
print("Symlink creation does not work on this platform. "
"Skipping all symlinking.")
printed_symlink_error = True
- if os.path.isfile(outname):
- try:
- depfixer.fix_rpath(outname, install_rpath, final_path,
- install_name_mappings, verbose=False)
- except SystemExit as e:
- if isinstance(e.code, int) and e.code == 0:
- pass
- else:
- raise
def run(args):
global install_log_file
parser = buildparser()