gnu: perl: Update to 5.30.0.

* gnu/packages/patches/perl-no-sys-dirs.patch: Adjust Errno.h hunk.
* gnu/packages/perl.scm (perl): Update to 5.30.0.
master
Marius Bakke 2019-05-23 18:14:01 +02:00
parent 1b4c3faff4
commit a3e53041b8
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
2 changed files with 18 additions and 9 deletions

View File

@ -112,20 +112,29 @@ Only in perl-5.20.0/: Configure.orig
diff -ru -x '*~' -x '*.rej' perl-5.20.0-orig/ext/Errno/Errno_pm.PL perl-5.20.0/ext/Errno/Errno_pm.PL diff -ru -x '*~' -x '*.rej' perl-5.20.0-orig/ext/Errno/Errno_pm.PL perl-5.20.0/ext/Errno/Errno_pm.PL
--- perl-5.20.0-orig/ext/Errno/Errno_pm.PL 2014-05-26 15:34:20.000000000 +0200 --- perl-5.20.0-orig/ext/Errno/Errno_pm.PL 2014-05-26 15:34:20.000000000 +0200
+++ perl-5.20.0/ext/Errno/Errno_pm.PL 2014-06-25 10:31:24.317970047 +0200 +++ perl-5.20.0/ext/Errno/Errno_pm.PL 2014-06-25 10:31:24.317970047 +0200
@@ -126,11 +126,7 @@ @@ -114,7 +114,7 @@ sub get_files {
# When cross-compiling we may store a path for gcc's "sysroot" option:
my $sysroot = $Config{sysroot} || '';
my $linux_errno_h;
- if ($^O eq 'linux') {
+ if (0) {
# Some Linuxes have weird errno.hs which generate
# no #file or #line directives
($linux_errno_h) = grep { -e $_ } map { "$_/errno.h" }
@@ -134,13 +134,6 @@ sub get_files {
if ($dep =~ /(\S+errno\.h)/) { if ($dep =~ /(\S+errno\.h)/) {
$file{$1} = 1; $file{$1} = 1;
} }
- } elsif ($^O eq 'linux' && - } elsif ($^O eq 'linux' &&
- $Config{gccversion} ne '' && - $Config{gccversion} ne '' &&
- $Config{gccversion} !~ /intel/i - $Config{gccversion} !~ /intel/i &&
- # might be using, say, Intel's icc - # might be using, say, Intel's icc
- $linux_errno_h
- ) { - ) {
+ } elsif (0) { - $file{$linux_errno_h} = 1;
# When cross-compiling we may store a path for gcc's "sysroot" option: } elsif ($^O eq 'haiku') {
my $sysroot = $Config{sysroot} || ''; # hidden in a special place
# Some Linuxes have weird errno.hs which generate $file{'/boot/develop/headers/posix/errno.h'} = 1;
Only in perl-5.20.0/ext/Errno: Errno_pm.PL.orig
diff -ru -x '*~' -x '*.rej' perl-5.20.0-orig/hints/freebsd.sh perl-5.20.0/hints/freebsd.sh diff -ru -x '*~' -x '*.rej' perl-5.20.0-orig/hints/freebsd.sh perl-5.20.0/hints/freebsd.sh
--- perl-5.20.0-orig/hints/freebsd.sh 2014-01-31 22:55:51.000000000 +0100 --- perl-5.20.0-orig/hints/freebsd.sh 2014-01-31 22:55:51.000000000 +0100
+++ perl-5.20.0/hints/freebsd.sh 2014-06-25 10:25:53.263964680 +0200 +++ perl-5.20.0/hints/freebsd.sh 2014-06-25 10:25:53.263964680 +0200

View File

@ -65,14 +65,14 @@
;; Yeah, Perl... It is required early in the bootstrap process by Linux. ;; Yeah, Perl... It is required early in the bootstrap process by Linux.
(package (package
(name "perl") (name "perl")
(version "5.28.2") (version "5.30.0")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "mirror://cpan/src/5.0/perl-" (uri (string-append "mirror://cpan/src/5.0/perl-"
version ".tar.gz")) version ".tar.gz"))
(sha256 (sha256
(base32 (base32
"1iynpsxdym4h76kgndmn3ykvwxhqz444xvaz8z2irsxkvmnlb5da")) "1wkmz6xn3fswpqhz29akiklcxclnlykhp96a8bqcz36rak3i64l5"))
(patches (search-patches (patches (search-patches
"perl-no-sys-dirs.patch" "perl-no-sys-dirs.patch"
"perl-autosplit-default-time.patch" "perl-autosplit-default-time.patch"