gnu: texinfo@5: Fix FTBFS with Perl >= 5.28.
* gnu/packages/patches/texinfo-5-perl-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/texinfo.scm (texinfo-5)[source](patches): New field.
This commit is contained in:
parent
16de7f15cb
commit
a446cf26d7
|
@ -1158,6 +1158,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/teensy-loader-cli-help.patch \
|
%D%/packages/patches/teensy-loader-cli-help.patch \
|
||||||
%D%/packages/patches/teeworlds-use-latest-wavpack.patch \
|
%D%/packages/patches/teeworlds-use-latest-wavpack.patch \
|
||||||
%D%/packages/patches/texinfo-perl-compat.patch \
|
%D%/packages/patches/texinfo-perl-compat.patch \
|
||||||
|
%D%/packages/patches/texinfo-5-perl-compat.patch \
|
||||||
%D%/packages/patches/texi2html-document-encoding.patch \
|
%D%/packages/patches/texi2html-document-encoding.patch \
|
||||||
%D%/packages/patches/texi2html-i18n.patch \
|
%D%/packages/patches/texi2html-i18n.patch \
|
||||||
%D%/packages/patches/thefuck-test-environ.patch \
|
%D%/packages/patches/thefuck-test-environ.patch \
|
||||||
|
|
|
@ -0,0 +1,19 @@
|
||||||
|
Fix a deprecation warning with newer Perl that breaks some tests.
|
||||||
|
|
||||||
|
--- a/tp/Texinfo/Parser.pm
|
||||||
|
+++ b/tp/Texinfo/Parser.pm
|
||||||
|
@@ -5438,12 +5438,12 @@
|
||||||
|
}
|
||||||
|
} elsif ($command eq 'clickstyle') {
|
||||||
|
# REMACRO
|
||||||
|
- if ($line =~ /^\s+@([[:alnum:]][[:alnum:]\-]*)({})?\s*/) {
|
||||||
|
+ if ($line =~ /^\s+@([[:alnum:]][[:alnum:]\-]*)(\{})?\s*/) {
|
||||||
|
$args = ['@'.$1];
|
||||||
|
$self->{'clickstyle'} = $1
|
||||||
|
unless(_ignore_global_commands($self));
|
||||||
|
$remaining = $line;
|
||||||
|
- $remaining =~ s/^\s+@([[:alnum:]][[:alnum:]\-]*)({})?\s*(\@(c|comment)((\@|\s+).*)?)?//;
|
||||||
|
+ $remaining =~ s/^\s+@([[:alnum:]][[:alnum:]\-]*)(\{})?\s*(\@(c|comment)((\@|\s+).*)?)?//;
|
||||||
|
$has_comment = 1 if (defined($4));
|
||||||
|
} else {
|
||||||
|
$self->line_error (sprintf($self->__(
|
|
@ -69,6 +69,7 @@ is on expressing the content semantically, avoiding physical markup commands.")
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/texinfo/texinfo-"
|
(uri (string-append "mirror://gnu/texinfo/texinfo-"
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
|
(patches (search-patches "texinfo-5-perl-compat.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1njfwh2z34r2c4r0iqa7v24wmjzvsfyz4vplzry8ln3479lfywal"))))
|
"1njfwh2z34r2c4r0iqa7v24wmjzvsfyz4vplzry8ln3479lfywal"))))
|
||||||
|
|
Loading…
Reference in New Issue