gnu: mozjs@17: Add support for aarch64-linux.
* gnu/packages/gnuzilla.scm (mozjs@17)[source]: Add patch. [arguments]: Add phase deleting slow test, add configure argument for building on aarch64-linux. * gnu/packages/patches/mozjs17-aarch64-support.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
26f38d313b
commit
a64b7da513
|
@ -767,6 +767,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/mpc123-initialize-ao.patch \
|
%D%/packages/patches/mpc123-initialize-ao.patch \
|
||||||
%D%/packages/patches/mplayer2-theora-fix.patch \
|
%D%/packages/patches/mplayer2-theora-fix.patch \
|
||||||
%D%/packages/patches/module-init-tools-moduledir.patch \
|
%D%/packages/patches/module-init-tools-moduledir.patch \
|
||||||
|
%D%/packages/patches/mozjs17-aarch64-support.patch \
|
||||||
%D%/packages/patches/mozjs24-aarch64-support.patch \
|
%D%/packages/patches/mozjs24-aarch64-support.patch \
|
||||||
%D%/packages/patches/multiqc-fix-git-subprocess-error.patch \
|
%D%/packages/patches/multiqc-fix-git-subprocess-error.patch \
|
||||||
%D%/packages/patches/mumps-build-parallelism.patch \
|
%D%/packages/patches/mumps-build-parallelism.patch \
|
||||||
|
|
|
@ -69,6 +69,7 @@
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1fig2wf4f10v43mqx67y68z6h77sy900d1w0pz9qarrqx57rc7ij"))
|
"1fig2wf4f10v43mqx67y68z6h77sy900d1w0pz9qarrqx57rc7ij"))
|
||||||
|
(patches (search-patches "mozjs17-aarch64-support.patch"))
|
||||||
(modules '((guix build utils)))
|
(modules '((guix build utils)))
|
||||||
(snippet
|
(snippet
|
||||||
;; Fix incompatibility with Perl 5.22+.
|
;; Fix incompatibility with Perl 5.22+.
|
||||||
|
@ -83,6 +84,9 @@
|
||||||
;; mkdir -p "system_wrapper_js/"
|
;; mkdir -p "system_wrapper_js/"
|
||||||
#:parallel-build? #f
|
#:parallel-build? #f
|
||||||
#:phases
|
#:phases
|
||||||
|
(alist-cons-after 'unpack 'delete-timedout-test
|
||||||
|
;; This test times out on slower hardware.
|
||||||
|
(lambda _ (delete-file "js/src/jit-test/tests/basic/bug698584.js"))
|
||||||
(alist-cons-before
|
(alist-cons-before
|
||||||
'configure 'chdir
|
'configure 'chdir
|
||||||
(lambda _
|
(lambda _
|
||||||
|
@ -95,8 +99,12 @@
|
||||||
(setenv "SHELL" (which "sh"))
|
(setenv "SHELL" (which "sh"))
|
||||||
(setenv "CONFIG_SHELL" (which "sh"))
|
(setenv "CONFIG_SHELL" (which "sh"))
|
||||||
(zero? (system*
|
(zero? (system*
|
||||||
"./configure" (string-append "--prefix=" out)))))
|
"./configure" (string-append "--prefix=" out)
|
||||||
%standard-phases))))
|
,@(if (string=? "aarch64-linux"
|
||||||
|
(%current-system))
|
||||||
|
'("--host=aarch64-unknown-linux-gnu")
|
||||||
|
'())))))
|
||||||
|
%standard-phases)))))
|
||||||
(home-page
|
(home-page
|
||||||
"https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey")
|
"https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey")
|
||||||
(synopsis "Mozilla javascript engine")
|
(synopsis "Mozilla javascript engine")
|
||||||
|
|
|
@ -0,0 +1,60 @@
|
||||||
|
https://build.opensuse.org/package/view_file/openSUSE:Factory/mozjs17/mozjs-aarch64-support.patch
|
||||||
|
|
||||||
|
index c071c33..90764c3 100644
|
||||||
|
--- a/js/src/assembler/jit/ExecutableAllocator.h
|
||||||
|
+++ b/js/src/assembler/jit/ExecutableAllocator.h
|
||||||
|
@@ -382,6 +382,12 @@ public:
|
||||||
|
{
|
||||||
|
reprotectRegion(start, size, Executable);
|
||||||
|
}
|
||||||
|
+#elif WTF_CPU_AARCH64 && WTF_PLATFORM_LINUX
|
||||||
|
+ static void cacheFlush(void* code, size_t size)
|
||||||
|
+ {
|
||||||
|
+ intptr_t end = reinterpret_cast<intptr_t>(code) + size;
|
||||||
|
+ __builtin___clear_cache(reinterpret_cast<char*>(code), reinterpret_cast<char*>(end));
|
||||||
|
+ }
|
||||||
|
#else
|
||||||
|
static void makeWritable(void*, size_t) {}
|
||||||
|
static void makeExecutable(void*, size_t) {}
|
||||||
|
diff --git a/js/src/assembler/wtf/Platform.h b/js/src/assembler/wtf/Platform.h
|
||||||
|
index 0c84896..e8763a7 100644
|
||||||
|
--- a/js/src/assembler/wtf/Platform.h
|
||||||
|
+++ b/js/src/assembler/wtf/Platform.h
|
||||||
|
@@ -325,6 +325,10 @@
|
||||||
|
#define WTF_THUMB_ARCH_VERSION 0
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+/* CPU(AArch64) - 64-bit ARM */
|
||||||
|
+#if defined(__aarch64__)
|
||||||
|
+#define WTF_CPU_AARCH64 1
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
/* WTF_CPU_ARMV5_OR_LOWER - ARM instruction set v5 or earlier */
|
||||||
|
/* On ARMv5 and below the natural alignment is required.
|
||||||
|
diff --git a/js/src/configure.in b/js/src/configure.in
|
||||||
|
index 15605b2..19fd704 100644
|
||||||
|
--- a/js/src/configure.in
|
||||||
|
+++ b/js/src/configure.in
|
||||||
|
@@ -1121,6 +1121,10 @@ arm*)
|
||||||
|
CPU_ARCH=arm
|
||||||
|
;;
|
||||||
|
|
||||||
|
+aarch64)
|
||||||
|
+ CPU_ARCH=aarch64
|
||||||
|
+ ;;
|
||||||
|
+
|
||||||
|
mips|mipsel)
|
||||||
|
CPU_ARCH="mips"
|
||||||
|
;;
|
||||||
|
diff --git a/mfbt/double-conversion/utils.h b/mfbt/double-conversion/utils.h
|
||||||
|
index 0eec2d9..fe26dab 100644
|
||||||
|
--- a/mfbt/double-conversion/utils.h
|
||||||
|
+++ b/mfbt/double-conversion/utils.h
|
||||||
|
@@ -58,6 +58,7 @@
|
||||||
|
defined(__mips__) || defined(__powerpc__) || \
|
||||||
|
defined(__sparc__) || defined(__sparc) || defined(__s390__) || \
|
||||||
|
defined(__SH4__) || defined(__alpha__) || \
|
||||||
|
+ defined(__aarch64__) || \
|
||||||
|
defined(_MIPS_ARCH_MIPS32R2)
|
||||||
|
#define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1
|
||||||
|
#elif defined(_M_IX86) || defined(__i386__) || defined(__i386)
|
Loading…
Reference in New Issue