gnu: owncloud-client: Update to 2.5.1.10973.

* gnu/packages/sync.scm (owncloud-client): Update to 2.5.1.10973.
* gnu/packages/patches/owncloud-disable-updatecheck.patch: Update patch.
This commit is contained in:
Efraim Flashner 2019-01-02 16:43:33 +02:00
parent 2879e605bf
commit a69f071537
No known key found for this signature in database
GPG Key ID: 41AAE7DCCA3D8351
2 changed files with 22 additions and 22 deletions

View File

@ -10,9 +10,9 @@ Last-Update: 2014-02-17
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/src/libsync/configfile.cpp --- a/src/libsync/configfile.cpp
+++ b/src/libsync/configfile.cpp +++ b/src/libsync/configfile.cpp
@@ -417,11 +417,14 @@ bool ConfigFile::skipUpdateCheck( const @@ -522,11 +522,14 @@ bool ConfigFile::skipUpdateCheck(const Q
QString con( connection ); if (connection.isEmpty())
if( connection.isEmpty() ) con = defaultConnection(); con = defaultConnection();
- QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, false); - QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, false);
+ QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, true); + QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, true);
@ -29,21 +29,21 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
void ConfigFile::setSkipUpdateCheck(bool skip, const QString &connection) void ConfigFile::setSkipUpdateCheck(bool skip, const QString &connection)
--- a/src/gui/generalsettings.cpp --- a/src/gui/generalsettings.cpp
+++ b/src/gui/generalsettings.cpp +++ b/src/gui/generalsettings.cpp
@@ -124,6 +124,7 @@ void GeneralSettings::loadMiscSettings() @@ -146,6 +149,7 @@ void GeneralSettings::loadMiscSettings()
void GeneralSettings::slotUpdateInfo() void GeneralSettings::slotUpdateInfo()
{ {
+ /* Guix doesn't want an autoupdater + /* Guix doesn't want an autoupdater
// Note: the sparkle-updater is not an OCUpdater if (ConfigFile().skipUpdateCheck() || !Updater::instance()) {
OCUpdater *updater = qobject_cast<OCUpdater*>(Updater::instance()); // updater disabled on compile
if (ConfigFile().skipUpdateCheck()) { _ui->updaterWidget->setVisible(false);
@@ -140,6 +141,9 @@ void GeneralSettings::slotUpdateInfo() @@ -174,6 +178,9 @@ void GeneralSettings::slotUpdateInfo()
// can't have those infos from sparkle currently _ui->updateChannel->setCurrentIndex(ConfigFile().updateChannel() == "beta" ? 1 : 0);
_ui->updatesGroupBox->setVisible(false); connect(_ui->updateChannel, static_cast<void (QComboBox::*)(int)>(&QComboBox::currentIndexChanged),
} this, &GeneralSettings::slotUpdateChannelChanged, Qt::UniqueConnection);
+ */ + */
+ //hide the update group box for Guix. + //hide the update group box for Guix.
+ _ui->updatesGroupBox->setVisible(false); + _ui->updaterWidget->setVisible(false);
} }
void GeneralSettings::saveMiscSettings() void GeneralSettings::slotUpdateChannelChanged(int index)

View File

@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU ;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il> ;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net> ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr> ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org> ;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
@ -48,14 +48,14 @@
(define-public owncloud-client (define-public owncloud-client
(package (package
(name "owncloud-client") (name "owncloud-client")
(version "2.4.1") (version "2.5.1.10973")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.owncloud.com/desktop/stable/" (uri (string-append "https://download.owncloud.com/desktop/stable/"
"owncloudclient-" version ".tar.xz")) "owncloudclient-" version ".tar.xz"))
(sha256 (sha256
(base32 "08xayz0alvypwa1bjmw1rmh4m3sclld4yq7kcbf264983icawqj4")) (base32 "19x4rbnqg7f7hspz1xy86b1q51q1n5y7yvq8kqc1m64n2r2s3srk"))
(patches (search-patches "owncloud-disable-updatecheck.patch")) (patches (search-patches "owncloud-disable-updatecheck.patch"))
(modules '((guix build utils))) (modules '((guix build utils)))
(snippet (snippet