gnu: xmodmap: Add patch to allow builds with GCC 4.8.
* gnu/packages/patches/xmodmap-asprintf.patch: New file. * gnu/packages/xorg.scm (xmodmap): Use it. * gnu-system.am (dist_patch_DATA): Add it.
This commit is contained in:
parent
07cec9a5b9
commit
a8300ef9fd
|
@ -275,6 +275,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/valgrind-glibc.patch \
|
||||
gnu/packages/patches/vpnc-script.patch \
|
||||
gnu/packages/patches/w3m-fix-compile.patch \
|
||||
gnu/packages/patches/xmodmap-asprintf.patch \
|
||||
gnu/packages/patches/xpdf-constchar.patch
|
||||
|
||||
bootstrapdir = $(guilemoduledir)/gnu/packages/bootstrap
|
||||
|
|
|
@ -0,0 +1,14 @@
|
|||
This patch allows the 'asprintf' declaration to be visible, by
|
||||
including <config.h>, which defines _GNU_SOURCE.
|
||||
|
||||
|
||||
--- xmodmap-1.0.7/xmodmap.c 2013-11-25 23:25:25.000000000 +0100
|
||||
+++ xmodmap-1.0.7/xmodmap.c 2013-11-25 23:25:27.000000000 +0100
|
||||
@@ -26,6 +26,7 @@ from The Open Group.
|
||||
|
||||
*/
|
||||
|
||||
+#include <config.h>
|
||||
#include <X11/Xos.h>
|
||||
#include <X11/Xlib.h>
|
||||
#include <stdio.h>
|
|
@ -22,6 +22,7 @@
|
|||
#:use-module (guix packages)
|
||||
#:use-module (guix download)
|
||||
#:use-module (guix build-system gnu)
|
||||
#:use-module (gnu packages)
|
||||
#:use-module (gnu packages bison)
|
||||
#:use-module (gnu packages compression)
|
||||
#:use-module (gnu packages flex)
|
||||
|
@ -3332,7 +3333,8 @@ tracking.")
|
|||
".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"1dg47lay4vhrl9mfq3cfc6741a0m2n8wd4ljagd21ix3qklys8pg"))))
|
||||
"1dg47lay4vhrl9mfq3cfc6741a0m2n8wd4ljagd21ix3qklys8pg"))
|
||||
(patches (list (search-patch "xmodmap-asprintf.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
`(("xproto" ,xproto)
|
||||
|
|
Loading…
Reference in New Issue