gnu: rct: Add missing headers, enable RTTI.

* gnu/packages/patches/rct-add-missing-headers.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/cpp.scm (rct): Use the patch, enable RTTI.
[source]: Use the patch to add missing headers from installation.
[arguments]: Enable RTTI in configure-flags.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
master
Fis Trivial 2018-01-21 19:31:16 +00:00 committed by Ludovic Courtès
parent 6055e88c0d
commit a893dc2f48
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 48 additions and 2 deletions

View File

@ -1054,6 +1054,7 @@ dist_patch_DATA = \
%D%/packages/patches/raptor2-heap-overflow.patch \
%D%/packages/patches/ratpoison-shell.patch \
%D%/packages/patches/rcs-5.9.4-noreturn.patch \
%D%/packages/patches/rct-add-missing-headers.patch \
%D%/packages/patches/readline-link-ncurses.patch \
%D%/packages/patches/readline-6.2-CVE-2014-2524.patch \
%D%/packages/patches/readline-7.0-mingw.patch \

View File

@ -68,7 +68,7 @@ operating system functions.")
(define-public rct
(let* ((commit "b3e6f41d9844ef64420e628e0c65ed98278a843a")
(revision "1")
(revision "2")
(version (git-version "0.0.0" revision commit)))
(package
(name "rct")
@ -82,11 +82,13 @@ operating system functions.")
(sha256
(base32
"1m2931jacka27ghnpgf1z1plkkr64z0pga4r4zdrfpp2d7xnrdvb"))
(patches (search-patches "rct-add-missing-headers.patch"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
'("-DWITH_TESTS=ON"))) ; To run the test suite
'("-DWITH_TESTS=ON" ; To run the test suite
"-DRCT_RTTI_ENABLED=ON")))
(native-inputs
`(("cppunit" ,cppunit)
("pkg-config" ,pkg-config)))

View File

@ -0,0 +1,43 @@
From: fis <ybbs.daans@hotmail.com>
Date: Sat, 20 Jan 2018 07:42:38 +0800
Subject: [PATCH] rct.cmake: Add missing headers.
---
rct.cmake | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)
diff --git a/rct.cmake b/rct.cmake
index 323e7b9..3e0ac6b 100644
--- a/rct.cmake
+++ b/rct.cmake
@@ -339,7 +339,27 @@ if (NOT RCT_NO_INSTALL)
rct/Timer.h
rct/Value.h
rct/WriteLocker.h
+ rct/CpuUsage.h
+ rct/DataFile.h
+ rct/Date.h
+ rct/EmbeddedLinkedList.h
+ rct/FinishMessage.h
+ rct/Flags.h
+ rct/Hash.h
+ rct/LinkedList.h
+ rct/Map.h
+ rct/MemoryMappedFile.h
+ rct/OnDestruction.h
+ rct/QuitMessage.h
+ rct/ResponseMessage.h
+ rct/ScriptEngine.h
+ rct/StackBuffer.h
+ rct/WindowsUnicodeConversion.h
DESTINATION include/rct)
+ install(FILES
+ json/json.hpp
+ DESTINATION include/rct/json)
+
install(EXPORT "rct" DESTINATION lib/cmake)
endif ()
--
2.13.6