gnu: gdk-pixbuf: Update to 2.36.9.

* gnu/packages/gtk.scm (gdk-pixbuf): Update to 2.36.9.
[source]: Remove obsolete patch.
* gnu/packages/patches/gdk-pixbuf-list-dir.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Marius Bakke 2017-09-02 16:51:10 +02:00
parent d0cc3a9879
commit aa3542e844
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 2 additions and 39 deletions

View File

@ -630,7 +630,6 @@ dist_patch_DATA = \
%D%/packages/patches/gcc-6-cross-environment-variables.patch \
%D%/packages/patches/gcr-disable-failing-tests.patch \
%D%/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch \
%D%/packages/patches/gdk-pixbuf-list-dir.patch \
%D%/packages/patches/gd-fix-gd2-read-test.patch \
%D%/packages/patches/gd-fix-tests-on-i686.patch \
%D%/packages/patches/gd-freetype-test-failure.patch \

View File

@ -427,7 +427,7 @@ highlighting and other features typical of a source code editor.")
(define-public gdk-pixbuf
(package
(name "gdk-pixbuf")
(version "2.36.6")
(version "2.36.9")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@ -435,8 +435,7 @@ highlighting and other features typical of a source code editor.")
name "-" version ".tar.xz"))
(sha256
(base32
"034279k49ydawnagqd7b1rz741n20k4y3grybzwp26zd146bjpj5"))
(patches (search-patches "gdk-pixbuf-list-dir.patch"))))
"02klisz3ly0bvflj39x49lnl4mnldsgvkjdvnla1as8szxqv44w0"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--with-x11")

View File

@ -1,35 +0,0 @@
Sort directory entries so that the output of
gdk-pixbuf-query-loaders is deterministic.
See: https://bugzilla.gnome.org/show_bug.cgi?id=777332
--- gdk-pixbuf-2.34.0/gdk-pixbuf/queryloaders.c.orig 2017-01-11 00:17:32.865843062 +0100
+++ gdk-pixbuf-2.34.0/gdk-pixbuf/queryloaders.c 2017-01-16 16:12:03.420667874 +0100
@@ -354,16 +354,27 @@
dir = g_dir_open (path, 0, NULL);
if (dir) {
+ GList *entries = NULL;
const char *dent;
while ((dent = g_dir_read_name (dir))) {
gint len = strlen (dent);
if (len > SOEXT_LEN &&
strcmp (dent + len - SOEXT_LEN, SOEXT) == 0) {
- query_module (contents, path, dent);
+ entries = g_list_append (entries, g_strdup (dent));
}
}
g_dir_close (dir);
+ /* Sort directory entries so that the output of
+ gdk-pixbuf-query-loaders is deterministic. */
+ entries = g_list_sort (entries, (GCompareFunc) strcmp);
+ GList *xentries;
+ for (xentries = entries; xentries; xentries = g_list_next (xentries)) {
+ dent = xentries->data;
+ query_module (contents, path, dent);
+ g_free (xentries->data);
+ }
+ g_list_free (entries);
}
#else
g_string_append_printf (contents, "# dynamic loading of modules not supported\n");