gnu: util-linux: Update to 2.32.
* gnu/packages/patches/util-linux-tests.patch: Adjust context. * gnu/packages/patches/util-linux-CVE-2018-7738.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/linux.scm (util-linux): Update to 2.32. [source](patches): Remove 'util-linux-CVE-2018-7738.patch'.
This commit is contained in:
parent
5f69388d70
commit
ab0bdd5456
|
@ -1131,7 +1131,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/unzip-overflow-long-fsize.patch \
|
||||
%D%/packages/patches/unzip-remove-build-date.patch \
|
||||
%D%/packages/patches/ustr-fix-build-with-gcc-5.patch \
|
||||
%D%/packages/patches/util-linux-CVE-2018-7738.patch \
|
||||
%D%/packages/patches/util-linux-tests.patch \
|
||||
%D%/packages/patches/upower-builddir.patch \
|
||||
%D%/packages/patches/valgrind-enable-arm.patch \
|
||||
|
|
|
@ -547,7 +547,7 @@ providing the system administrator with some help in common tasks.")
|
|||
(define-public util-linux
|
||||
(package
|
||||
(name "util-linux")
|
||||
(version "2.31.1")
|
||||
(version "2.32")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://kernel.org/linux/utils/"
|
||||
|
@ -555,9 +555,8 @@ providing the system administrator with some help in common tasks.")
|
|||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"04fzrnrr3pvqskvjn9f81y0knh0jvvqx4lmbz5pd4lfdm5pv2l8s"))
|
||||
(patches (search-patches "util-linux-tests.patch"
|
||||
"util-linux-CVE-2018-7738.patch"))
|
||||
"0d2758kjll5xqm5fpp3sww1h66aahx161sf2b60jxqv4qymrfwvc"))
|
||||
(patches (search-patches "util-linux-tests.patch"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
;; We take 'nologin' from Shadow, the 'logger' program from
|
||||
|
|
|
@ -1,49 +0,0 @@
|
|||
Fix CVE-2018-7738:
|
||||
|
||||
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-7738
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
https://github.com/karelzak/util-linux/commit/75f03badd7ed9f1dd951863d75e756883d3acc55
|
||||
|
||||
From 75f03badd7ed9f1dd951863d75e756883d3acc55 Mon Sep 17 00:00:00 2001
|
||||
From: Karel Zak <kzak@redhat.com>
|
||||
Date: Thu, 16 Nov 2017 16:27:32 +0100
|
||||
Subject: [PATCH] bash-completion: (umount) use findmnt, escape a space in
|
||||
paths
|
||||
|
||||
# mount /dev/sdc1 /mnt/test/foo\ bar
|
||||
# umount <tab>
|
||||
|
||||
has to return "/mnt/test/foo\ bar".
|
||||
|
||||
Changes:
|
||||
|
||||
* don't use mount | awk output, we have findmnt
|
||||
* force compgen use \n as entries separator
|
||||
|
||||
Addresses: https://github.com/karelzak/util-linux/issues/539
|
||||
Signed-off-by: Karel Zak <kzak@redhat.com>
|
||||
---
|
||||
bash-completion/umount | 9 +++++----
|
||||
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/bash-completion/umount b/bash-completion/umount
|
||||
index d76cb9fff..98c90d61a 100644
|
||||
--- a/bash-completion/umount
|
||||
+++ b/bash-completion/umount
|
||||
@@ -40,9 +40,10 @@ _umount_module()
|
||||
return 0
|
||||
;;
|
||||
esac
|
||||
- local DEVS_MPOINTS
|
||||
- DEVS_MPOINTS="$(mount | awk '{print $1, $3}')"
|
||||
- COMPREPLY=( $(compgen -W "$DEVS_MPOINTS" -- $cur) )
|
||||
- return 0
|
||||
+
|
||||
+ local oldifs=$IFS
|
||||
+ IFS=$'\n'
|
||||
+ COMPREPLY=( $( compgen -W '$(findmnt -lno TARGET | sed "s/\([[:blank:]]\)/\\\\\1/g")' -- "$cur" ) )
|
||||
+ IFS=$oldifs
|
||||
}
|
||||
complete -F _umount_module umount
|
|
@ -5,14 +5,14 @@ using 'getpwnam' in libmount. This doesn't work in the chroot because
|
|||
|
||||
--- util-linux-2.25.2/tests/ts/libmount/optstr 2015-01-23 13:58:41.181151194 +0100
|
||||
+++ util-linux-2.25.2/tests/ts/libmount/optstr 2015-01-23 13:58:42.829161716 +0100
|
||||
@@ -84,10 +84,6 @@ ts_init_subtest "apply-user" # add user,
|
||||
ts_valgrind $TESTPROG --apply --user "noexec,nosuid,loop=/dev/looop0" 0x408 &> $TS_OUTPUT
|
||||
@@ -108,10 +108,6 @@
|
||||
ts_run $TESTPROG --apply --user "noexec,nosuid,loop=/dev/looop0" 0x408 &> $TS_OUTPUT
|
||||
ts_finalize_subtest
|
||||
|
||||
-ts_init_subtest "fix"
|
||||
-ts_valgrind $TESTPROG --fix "uid=root,gid=root" &> $TS_OUTPUT
|
||||
-ts_run $TESTPROG --fix "uid=root,gid=root" &> $TS_OUTPUT
|
||||
-ts_finalize_subtest
|
||||
-
|
||||
ts_init_subtest "deduplicate"
|
||||
ts_valgrind $TESTPROG --dedup bbb,ccc,AAA,xxx,AAA=a,AAA=bbb,ddd,AAA=ccc,fff=eee AAA &> $TS_OUTPUT
|
||||
ts_run $TESTPROG --dedup bbb,ccc,AAA,xxx,AAA=a,AAA=bbb,ddd,AAA=ccc,fff=eee AAA &> $TS_OUTPUT
|
||||
ts_finalize_subtest
|
||||
|
|
Loading…
Reference in New Issue