gnu: asymptote: Update to 2.37.

* gnu/packages/plotutils.scm (asymptote): Update to 2.37.
* gnu/packages/patches/asymptote-gsl2.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove reference.
master
Nicolas Goaziou 2016-04-30 11:43:35 +02:00 committed by Leo Famulari
parent 63bcec7140
commit acb31b5dcd
No known key found for this signature in database
GPG Key ID: 2646FA30BACA7F08
3 changed files with 16 additions and 44 deletions

View File

@ -415,7 +415,6 @@ dist_patch_DATA = \
gnu/packages/patches/alsa-lib-mips-atomic-fix.patch \
gnu/packages/patches/apr-skip-getservbyname-test.patch \
gnu/packages/patches/arb-ldconfig.patch \
gnu/packages/patches/asymptote-gsl2.patch \
gnu/packages/patches/ath9k-htc-firmware-binutils.patch \
gnu/packages/patches/ath9k-htc-firmware-gcc.patch \
gnu/packages/patches/ath9k-htc-firmware-objcopy.patch \

View File

@ -1,33 +0,0 @@
From 71ff9e769ba5d9995b367201f0d41b7a8dedab9d Mon Sep 17 00:00:00 2001
From: John Bowman <bowman@ualberta.ca>
Date: Sat, 14 Nov 2015 01:25:56 -0700
Subject: [PATCH] Support GSL 2.0.
---
gsl.cc | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/gsl.cc b/gsl.cc
index b500557..0f81dc6 100644
--- a/gsl.cc
+++ b/gsl.cc
@@ -27,6 +27,7 @@
#include <gsl/gsl_rng.h>
#include <gsl/gsl_randist.h>
#include <gsl/gsl_cdf.h>
+#include <gsl/gsl_version.h>
#include "opsymbols.h"
@@ -1088,7 +1089,11 @@ void gen_rungsl_venv(venv &ve)
addGSLDOUBLE2Func<gsl_sf_ellint_F>(SYM(F));
addGSLDOUBLE2Func<gsl_sf_ellint_E>(SYM(E));
addGSLDOUBLE3Func<gsl_sf_ellint_P>(SYM(P),SYM(phi),SYM(k),SYM(n));
+#if GSL_MAJOR_VERSION >= 2
+ addGSLDOUBLE2Func<gsl_sf_ellint_D>(SYM(D),SYM(phi),SYM(k));
+#else
addGSLDOUBLE3Func<gsl_sf_ellint_D>(SYM(D),SYM(phi),SYM(k),SYM(n));
+#endif
addGSLDOUBLE2Func<gsl_sf_ellint_RC>(SYM(RC),SYM(x),SYM(y));
addGSLDOUBLE3Func<gsl_sf_ellint_RD>(SYM(RD),SYM(x),SYM(y),SYM(z));
addGSLDOUBLE3Func<gsl_sf_ellint_RF>(SYM(RF),SYM(x),SYM(y),SYM(z));

View File

@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@ -171,15 +172,14 @@ colors, styles, options and details.")
(define-public asymptote
(package
(name "asymptote")
(version "2.35")
(version "2.37")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/asymptote/"
version "/asymptote-" version ".src.tgz"))
(sha256
(base32
"11f28vxw0ybhvl7vxmqcdwvw7y6gz55ykw9ybgzb2px6lsvgag7z"))
(patches (search-patches "asymptote-gsl2.patch"))))
"16nh02m52mk9a53i8wc6l9vg710gnzr3lfbypcbvamghvaj0458i"))))
(build-system gnu-build-system)
;; Note: The 'asy' binary retains a reference to docdir for use with its
;; "help" command in interactive mode, so adding a "doc" output is not
@ -206,13 +206,19 @@ colors, styles, options and details.")
(string-append "--with-context="
(assoc-ref %outputs "out")
"/share/texmf/tex/context/third"))
#:phases (modify-phases %standard-phases
(add-before 'build 'patch-pdf-viewer
(lambda _
;; Default to a free pdf viewer
(substitute* "settings.cc"
(("defaultPDFViewer=\"acroread\"")
"defaultPDFViewer=\"gv\"")))))))
#:phases
(modify-phases %standard-phases
(add-before 'build 'patch-pdf-viewer
(lambda _
;; Default to a free pdf viewer
(substitute* "settings.cc"
(("defaultPDFViewer=\"acroread\"")
"defaultPDFViewer=\"gv\""))))
(add-before 'check 'set-HOME
;; Some tests require write access to $HOME, otherwise leading to
;; "failed to create directory /homeless-shelter/.asy" error.
(lambda _
(setenv "HOME" "/tmp"))))))
(home-page "http://asymptote.sourceforge.net")
(synopsis "Script-based vector graphics language")
(description