gnu: thermald: Update to 1.8.
* gnu/packages/admin.scm (thermald): Update to 1.8. [source]: Add patch. * gnu/packages/patches/thermald-make-int-max32-visible.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
96f39b2a6e
commit
ad257ec8b5
|
@ -1277,6 +1277,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/texi2html-document-encoding.patch \
|
||||
%D%/packages/patches/texi2html-i18n.patch \
|
||||
%D%/packages/patches/thefuck-test-environ.patch \
|
||||
%D%/packages/patches/thermald-make-int-max32-visible.patch \
|
||||
%D%/packages/patches/tidy-CVE-2015-5522+5523.patch \
|
||||
%D%/packages/patches/tinyxml-use-stl.patch \
|
||||
%D%/packages/patches/tipp10-fix-compiling.patch \
|
||||
|
|
|
@ -2523,7 +2523,7 @@ make it a perfect utility on modern distros.")
|
|||
(define-public thermald
|
||||
(package
|
||||
(name "thermald")
|
||||
(version "1.7.2")
|
||||
(version "1.8")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
|
@ -2532,8 +2532,9 @@ make it a perfect utility on modern distros.")
|
|||
(commit (string-append "v" version))))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"1cs2pq8xvfnsvrhg2bxawk4kn3z1qmfrnpnhs178pvfbglzh15hc"))))
|
||||
(base32 "1g1l7k8yxj8bl1ysdx8v6anv1s7xk9j072y44gwki70dy48n7j92"))
|
||||
(patches
|
||||
(search-patches "thermald-make-int-max32-visible.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:configure-flags
|
||||
|
|
|
@ -0,0 +1,24 @@
|
|||
From 5fb947886bf1e40475edf930fb2b284c24c8cb9a Mon Sep 17 00:00:00 2001
|
||||
From: Sanel Zukan <karijes@users.sourceforge.net>
|
||||
Date: Sun, 23 Dec 2018 00:04:34 +0100
|
||||
Subject: [PATCH] Make sure INT_MAX32 is visible.
|
||||
|
||||
---
|
||||
src/thd_trip_point.h | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/thd_trip_point.h b/src/thd_trip_point.h
|
||||
index 0eedc95..89eb083 100644
|
||||
--- a/src/thd_trip_point.h
|
||||
+++ b/src/thd_trip_point.h
|
||||
@@ -29,6 +29,10 @@
|
||||
#include "thd_sys_fs.h"
|
||||
#include "thd_preference.h"
|
||||
#include "thd_cdev.h"
|
||||
+
|
||||
+#define __STDC_LIMIT_MACROS
|
||||
+#include <stdint.h>
|
||||
+
|
||||
#include <time.h>
|
||||
#include <vector>
|
||||
#include <algorithm> // std::sort
|
Loading…
Reference in New Issue